It's all about the answers!

Ask a question

Unable to extract RTC custom field data which is having slash in custom field id


Prabakaran Ramakrishnan (111) | asked Jun 30 '23, 12:54 p.m.

 Hi Team,


We are using CLM 6.0.6 version and we are trying to extract one of the RTC workitem [action item] field data via postman using OSLC API query, https://adtclmemeastg00102.accenture.com/ccm/resource/itemName/com.ibm.team.workitem.WorkItem/150

 In the OSLC response we are getting the extract result as below,

<?xml version="1.0" encoding="UTF-8"?>
         xmlns:acc="http://open-services.net/ns/core/acc#"
         xmlns:oslc_cmx="http://open-services.net/ns/cm-x#"
         xmlns:oslc_pl="http://open-services.net/ns/pl#"
         xmlns:rtc_cm="http://jazz.net/xmlns/prod/jazz/rtc/cm/1.0/"
         xmlns:process="http://jazz.net/ns/process#"
         xmlns:dcterms="http://purl.org/dc/terms/"
         xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
         xmlns:rtc_ext="http://jazz.net/xmlns/prod/jazz/rtc/ext/1.0/"
         xmlns:acp="http://jazz.net/ns/acp#"
         xmlns:oslc="http://open-services.net/ns/core#"
         xmlns:oslc_cm="http://open-services.net/ns/cm#"> 
      <dcterms:title>Work Items</dcterms:title>
      <oslc:totalCount>1</oslc:totalCount>
      <rdf:type rdf:resource="http://open-services.net/ns/core#ResponseInfo"/>
  </rdf:Description>
  </rdf:Description>
</rdf:RDF>   

In this result we are getting response for the custom field rtc_ext:com.acn.adt.actionitem.attribute.yesno along with slash in it i.e Yes/No_Live/Yes/No_Live.literal.l1, We would like to get the custom field value by hitting the resource URL, https://adtclmemeastg00102.accenture.com/ccm/oslc/enumerations/_Zs1KAM0kEe2LRs7Bz6g7hw/Yes/No_Live/Yes/No_Live.literal.l1, Since the field is having slash in the field name which is coming along with URL response, we are getting 404 Not Found error while hitting. We have replaced slash with "%2F" as per url encryption standard but still getting the 404 error.

 Anyone can kindly help us on this?

One answer



permanent link
David Honey (1.8k17) | answered Jul 03 '23, 4:07 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Why not use underscore instead of forward slash?
The property id is being used to form a URL so probably shouldn't contain a forward slash.


Comments
Prabakaran Ramakrishnan commented Jul 03 '23, 5:21 a.m.
Thanks for your response!

Since we already created custom field id with underscore, we can not change it now. If recreate, we are loosing the data. Is there any alternative way to get those data?


Thanks in advance,
Prabakaran


David Honey commented Jul 03 '23, 11:33 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Have you tried specifying an External URI for the attribute?

Your answer


Register or to post your answer.