It's all about the answers!

Ask a question

how to find the REST API id of an RQM asset

Karen Steele (1.2k2137146) | asked May 05 '22, 10:04 a.m.

 I am using the RQMCopyUtility (yes I know its unsupported), but as its given out with all installation I'm trying to use this to get some data from one server environment to another.   I wanted to test it out using a specific RQM test plan ID (177) which is the UUID .. the RQMCopy utility fails as its looking for REST API id of the asset not the UUID

How do we find what that is ... here is the jar command line I'm running 

java -jar RQMCopyUtility.jar -s=https://{servermame}:9443/qm/secure/service/{projectname} -us=username -pws=userpswd -d=https://{servername}:9443/qm/{project name} -artifactType=testplan -artifactId=177 -i=remotescript -l=importlog.txt -force

One answer

permanent link
Ralph Schoon (63.3k33646) | answered May 06 '22, 3:29 a.m.
edited May 06 '22, 4:55 a.m.

 As per the documentation the URL to get the RQM asset with the reportable REST API based on your data above is: 


I am unsure about that might be incorrect. 

<o:p> </o:p>

Note that mine looks a bit different my <integrationUrl> is https://{servermame}:9443/qm/service/ . (rqm not qm in the middle)
So mine is: 
qm/service/{projectname}/{artifactType}/{artifactType}:{artifactId} (based on 7.0.2)

<o:p> </o:p>

The ETM Reportable REST API (is the only reportable jazz REST API that) supports PUT and POST operations. This might actually help supporting your use case. See this recent post: 

Otherwise OSLC would be the API to look at. 

<o:p> </o:p>

Karen Steele commented May 06 '22, 8:55 a.m.

  I got a result, but I've tried all combinations of the value but the importlog returns this

06 May 2022 08:51:15,847-0400 [main]  INFO Attempting to create SSL_TLS context
06 May 2022 08:51:20,591-0400 [main]  INFO Starting: testplan tLZPoEGrEeiRIPLF5q7cbA

and ultimately fails 

in my return response from the URL this tLZPoEGrEeiRIPLF5q7cbA
 is also prefixed with slug__ which I added and still fails and also has a 177 at the end also tried and also failed. 

Ralph Schoon commented May 06 '22, 9:44 a.m.
If you want to use the composed URL, you have to perform a GET on that URL. I do not know if the URL Util uses them. The documentation explains what a slug is.

The information given is pretty thin. Good luck, I am off for the next weeks. 

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.