It's all about the answers!

Ask a question

Integration of Android studio with ewm eclipse client.

raj ahmed (111) | asked Apr 12 '22, 4:32 a.m.


I was trying to integrate android studio with eclipse client and followed each and every step which was present in this document(How to Set Up RTC for Android Development on Windows | Best Practices for Building Software Platforms (

So, i was stuck at last step in editing the .ini file at eclipse repository location and when i'm giving the jdk location in .ini file as follows

C:\Program Files\Java\jdk1.6.0_21\bin)

After editing .ini file and saving it then after i was not able to open my eclipse client.

Kindly please anyone look into this.


Shaik Raj

2 answers

permanent link
Ralph Schoon (63.2k33646) | answered Apr 12 '22, 5:41 a.m.

 What error message do you get?

Did you actually install this old JDK? I am pretty sure that you should not use such an old version.
Which EWM version? Current version such as 6.0.6.x and 7.0.x require Java 8.
Did you try to provide a windows path without space e.g. c:\Pragram~1....

raj ahmed commented Apr 12 '22, 6:18 a.m.

Yes my ewm version is 7.0.2

I tried with java 6,8 but still cant open my eclipse after editing .ini file

The error message i got when im opening eclipse client is "FAILED TO CREATE JAVA VIRTUAL MACHINE".

If possible please make a meet-up and please solve this, im working on this setup since yesterday but not able to complete it. 

Ralph Schoon commented Apr 12 '22, 6:53 a.m. | edited Apr 12 '22, 6:54 a.m.

Sorry, I am not available for meetups. 

1. explains how to do this if you want to start with an Eclipse and install RTC into that. See lab 1.
2. If you download one of the ZIP versions of the RTC client, they ship their own compatible IBM Java in the subfolder JDK.
3. RTC 7.0.2 requires Java 8, which it ships. 
4. If you want to use Oracle Java, you have to change the VM argument. 
5. I avoid BLANKS in path names. In  windows try brackets or the 8.3 names with dir /X

Ralph Schoon commented Apr 12 '22, 7:24 a.m.

PS: if Android Studio is based on GIT, it would likely be better to stay wit GIT. Using EWM/RTC then would be more focused on change management and planning. 

raj ahmed commented Apr 13 '22, 12:42 p.m.

 When i had given path to edit the line that specifies the virtual machine so it points to the directory that holds the JVM for JDK 1.8.

It was showing the error when im opening eclipse client was "Failed to load the JNI library "C\PF........."

I had tried each and every step but after giving path in .ini file im getting that error pop up 

Michael Rowe commented May 12 '22, 8:31 a.m.

Are you running on macOS or Windows?  I've seen the above error message on macOS with issues in the eclipse.ini file. 

permanent link
Davyd Norris (2.3k217) | answered Apr 13 '22, 11:13 p.m.
edited Apr 13 '22, 11:14 p.m.
The latest versions of Android Studio and EWM all use later JRE versions and you shouldn't edit the ini file

The document you're using is for a much, much older version of both tools

Ralph Schoon commented Apr 14 '22, 2:15 a.m. | edited Apr 14 '22, 2:22 a.m.


However there are also other reasons why you would want to edit that file and add the VM argument. This is just Eclipse and has nothing to do with RTC at all. You can avoid the VM entry if you have the correct java version in the path.

If you do not have Java on the path the VM argument is essential to be set if you install a plain Eclipse, otherwise it will not start.

However it is also not exactly rocket science. On Windows I would suggest to try not to have spaces in paths or try brackets like ". I have always used the first approach when using Oracle Java. I would have the following set:


in my exlipse.ini. I have seen both forms, not sure what is going on. Note, it is two lines.

raj ahmed commented May 11 '22, 1:58 a.m.


How to push the code from Android studio to RTC and how to verify that my integration went successful.

Shaik Raj Ahammad 

Davyd Norris commented May 12 '22, 5:43 p.m.

This is just standard EWM online help info - have a look in the Knowledge Center for how to add a project to source control and how to check in and deliver to a stream

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.