It's all about the answers!

Ask a question

Compatibility issues between Eclipse 4.22/ 4.23 and EWM 7.0.2


Andrew Tram (11) | asked Mar 26, 8:10 p.m.

 I've seen this following issues when install EWM 702 on top of Eclipse 4.22 and 4.23:

org.osgi.framework.BundleException: Could not resolve module: com.ibm.team.filesystem.ide.ui [748]
  Unresolved requirement: Require-Bundle: com.ibm.team.process.ide.ui
    -> Bundle-SymbolicName: com.ibm.team.process.ide.ui; bundle-version="1.3.8000.v20200825_0118"; singleton:="true"
       com.ibm.team.process.ide.ui [777]
         No resolution report for the bundle.  Bundle was not resolved because of a uses constraint violation.
  org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource com.ibm.team.process.ide.ui [osgi.identity; osgi.identity="com.ibm.team.process.ide.ui"; type="osgi.bundle"; version:Version="1.3.8000.v20200825_0118"; singleton:="true"] because it is exposed to package 'javax.servlet' from resources javax.servlet [osgi.identity; osgi.identity="javax.servlet"; type="osgi.bundle"; version:Version="3.0.0.v201112011016"] and jakarta.servlet-api [osgi.identity; type="osgi.bundle"; version:Version="4.0.0"; osgi.identity="jakarta.servlet-api"] via two dependency chains.

Chain 1:
  com.ibm.team.process.ide.ui [osgi.identity; osgi.identity="com.ibm.team.process.ide.ui"; type="osgi.bundle"; version:Version="1.3.8000.v20200825_0118"; singleton:="true"]
    require: (osgi.wiring.bundle=javax.servlet)
     |
    provide: osgi.wiring.bundle: javax.servlet
  javax.servlet [osgi.identity; osgi.identity="javax.servlet"; type="osgi.bundle"; version:Version="3.0.0.v201112011016"]

Chain 2:
  com.ibm.team.process.ide.ui [osgi.identity; osgi.identity="com.ibm.team.process.ide.ui"; type="osgi.bundle"; version:Version="1.3.8000.v20200825_0118"; singleton:="true"]
    require: (osgi.wiring.bundle=com.ibm.team.foundation.common)
     |
    provide: osgi.wiring.bundle; bundle-version:Version="1.3.7000.v20200604_0355"; osgi.wiring.bundle="com.ibm.team.foundation.common"; singleton:="true"
  org.apache.commons.logging [osgi.identity; type="osgi.bundle"; version:Version="1.2.0.v20180409-1502"; osgi.identity="org.apache.commons.logging"]
    import: (osgi.wiring.package=javax.servlet)
     |
    export: osgi.wiring.package: javax.servlet
  jakarta.servlet-api [osgi.identity; type="osgi.bundle"; version:Version="4.0.0"; osgi.identity="jakarta.servlet-api"]
at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1847)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1840)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1781)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1745)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1667)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

This issues can be seen after install and going to the Team Artifacts view - some links like connecting to a repository workspace are missing and triggers those wiring errors.

It seems to have worked up to Eclipse 4.21, but something has changed with Eclipse since then to cause it to no longer work. I understand that EWM doesn't claim support past 4.16, but I was still wondering if someone could look into the issue.


Comments
Andrew Tram commented Mar 26, 8:26 p.m.

  Interestingly enough, Eclipse 4.23 does include a lower version of javax.servlet compared to 4.21 - javax.servlet_3.0.0.v201112011016.jar vs javax.servlet_3.1.0.v201410161800.jar


Andrew Tram commented Mar 26, 8:50 p.m.

 Eclipse 4.21, javax.servlet_3.1.0.v201410161800

Bundle-SymbolicName: javax.servlet
 ls:org.eclipse.orbit/javax.servlet;tag=v201410161800
Bundle-Version: 3.1.0.v201410161800
Export-Package: javax.servlet;version="3.1.0";uses:="javax.servlet.des
 criptor,javax.servlet.annotation",javax.servlet.annotation;version="3
 .1.0";uses:="javax.servlet",javax.servlet.descriptor;version="3.1.0",
 javax.servlet.http;version="3.1.0";uses:="javax.servlet"


Andrew Tram commented Mar 26, 8:51 p.m.

 Eclipse 4.23, javax.servlet_3.0.0.v201112011016

Bundle-SymbolicName: javax.servlet
 ls:org.eclipse.orbit/javax.servlet;tag=v201112011016
Export-Package: javax.servlet;version="2.6.0";uses:="javax.servlet.ann
 otation,javax.servlet.descriptor",javax.servlet.annotation;version="2
 .6.0";uses:="javax.servlet",javax.servlet.descriptor;version="2.6.0",
 javax.servlet.http;version="2.6.0";uses:="javax.servlet",javax.servle
 t.resources;version="2.6.0"
Bundle-Version: 3.0.0.v201112011016


Ralph Schoon commented Mar 29, 2:09 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Do you use the  P2 install?


Andrew Tram commented Mar 29, 6:25 p.m.

That's correct. It was a P2 install on top of Eclipse Eclipse IDE for RCP and RAP Developers 4.22/ 4.23

3 answers



permanent link
Andrew Tram (11) | answered Mar 30, 5:42 p.m.

Interestingly enough, starting with Eclipse 4.21, checking for updates and moving it up to 4.23, then install EWM 7.0.2 works.


permanent link
David Honey (1.1k7) | answered Mar 30, 4:50 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I use Eclipse 2021-06 (4.20) with an EWM 7.0.2 p2 plugin for my everyday Jazz development. That version requires Java 11 to run. I tried Eclipse 2021-12, but there was a problem with the EWM 7.0.2 plugin with that Eclipse, for which a defect was submitted. However, as Ralph mentions, Eclipse versions later than 4.16 are currently not officially supported.


permanent link
Ralph Schoon (61.1k33643) | answered Mar 30, 2:50 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Mar 30, 3:44 a.m.

I have not used the latest and greatest Eclipse version with EWM lately. I have seen issues in the past. 



Go to All Platforms. Eclipse support is documented in the Prerequisites. The link I get does not work here. 

Supported versions are 4.4, 4.5, 4.6, and now the ones with future fixpacks 4.7, 4.8, 4.11, 4.14, 4.16

There is no support for the versions you list, as far as I can tell. 

Also note the Java SDK currently only Java 8 is supported at the moment.

Your answer


Register or to post your answer.