It's all about the answers!

Ask a question

EWM 7.0.2 plain java API: version mismatch for the "com.ibm.team.repository" service


Anbe Pham (403) | asked Oct 21 '21, 3:13 a.m.
Hello all,

Current our server version is 7.0.2 plus candidate M5.
When I using java plain API version 7.0.2, I cannot connect to our server.
The error is: CRJAZ0056I There is a version mismatch for the "com.ibm.team.repository" service.  The server version is "45" while the client version is "43".

If I use java plain API version 6.0.6.1, I can connect and almost APIs are working correctly, except APIs attaching file to workitem. So I need to use java plain API version 7.0.2, but my code cannot connect to server anymore.

What should I do now?

Accepted answer


permanent link
Anbe Pham (403) | answered Oct 22 '21, 3:30 a.m.
Error program used Java 8.
I change to java 11 and it works now.
Thank you for your support.
Ralph Schoon selected this answer as the correct answer

Comments
Ralph Schoon commented Oct 22 '21, 8:32 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Also note that some of the downloads, including the Eclipse client, JBE, contain the IBM Java with the correct version, correct architecture. You can always use one of those.

One other answer



permanent link
Ralph Schoon (60.5k33643) | answered Oct 21 '21, 5:00 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 Ask if your contacts can make a 7.0.2 plus candidate M5 plain Java Client Libraries available.


Comments
Ralph Schoon commented Oct 21 '21, 5:01 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The same should happen with the Eclipse client. This is a problem. 


Anbe Pham commented Oct 21 '21, 6:33 a.m.

The eclipse client is working normally. Only my java program cannot connect with server.


Ralph Schoon commented Oct 21 '21, 6:38 a.m. | edited Oct 21 '21, 6:44 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This does not make sense to me. The code used by the Plain Java Client Libraries is exactly the code used by the RTC SDK and the Eclipse client.  Please check, if you are really using the plain Java Client Libraries for 7.0.2 and not an older version. Also make sure to use at least Java 8. Check the URL.


Ralph Schoon commented Oct 21 '21, 8:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I have not seen any issues with with the Plain Java client libraries when upgrading from  6.0.6.1 to 7.0.x. One import one is, that the Java Version has to be at least 1.8 


If you can connect to a 7.0.x server with a 6.0.6.1 Plain Java client, you should be able to do the same with a 7.0.2 Plain Java Client. 

Your answer


Register or to post your answer.