It's all about the answers!

Ask a question

DNG: OpenSocial-Gadget is not loaded. CRJAZ5037E

Ulrich Simon (1513) | asked Jul 26 '21, 3:27 a.m.

I have created an OpenSocial-Gadget, copied it into  .\JazzTeamServer\server\liberty\servers\clm\dropins\war\extensions and added it to a WidgetCatalog.xml file. I referenced this file in the Advanced Properties of DNG and adapted server.xml to enable dropins. I did this on 2 installation of DNG 7.0.2.

In both installations, the new Gadget is shown in the selection view to add a widget to a dashboard and I can add the gadget to my Minidashboard. In one installation, the gadget is loaded and is working.
On the other installation, the gadget is not loaded but error CRJAZ5037E appears. There is no error message in the Browser Console. I am able to retrieve the Gadget-xml-File in a browser directly on the Jazz-Server. I cannot find any message in any log file.

Accepted answer

permanent link
Ian Barnard (1.9k613) | answered Jul 26 '21, 3:58 a.m.

ELM 7.0.2 iFix004, ELM 7.0.1 iFix009, CLM iFix018, and CLM 6.0.6 iFix022 (and later) have increased level of security on OpenSocial widgets; see for how to change settings on the server to allow the widgets to work.

Ulrich Simon selected this answer as the correct answer

Bartosz Chrabski commented Jul 26 '21, 4:02 a.m.

 Yes, that is true.

3 other answers

permanent link
Ragavendhren Balasubramanain (111) | answered Jan 03, 6:08 a.m.
edited Jan 03, 6:20 a.m.
I'm curious about the necessity of whitelisting for Cloud Trail. It seems that the Cloud Trail version lacks access to extension URL whitelisting options. I'm also wondering if there's a way to test custom widgets in Cloud Trail. Any insights or guidance on these aspects would be greatly appreciated!

I get this error while adding a simple hello world widget.
The OpenSocial gadget was not loaded.ID CRJAZ5037E
The application cannot reach the gadget. The gadget might have been removed from its host server.
Remove the gadget from your dashboard and add it again, being sure to use the correct address. If the problem still exists, the host server cannot be reached and no resolution exists.

permanent link
Manju Gowda (37110) | answered Dec 08 '22, 7:17 a.m.

instead of rm/admin, go to jts/admin. This is for 702

permanent link
Bartosz Chrabski (3.4k12648) | answered Jul 26 '21, 3:36 a.m.
edited Jul 26 '21, 3:37 a.m.


Please go to rm/admin and selected Advanced Properties.

Search for

Next change value of External resources allowance list to *.

It will solve your problem.


Ian Barnard commented Jul 26 '21, 3:59 a.m.

The change in behaviour was made to decrease SSRF vulnerability, but using * will bypass this - you should use specific URLs.

Bartosz Chrabski commented Jul 26 '21, 4:02 a.m.


Your answer

Register or to post your answer.