It's all about the answers!

Ask a question

Is it possible to generate a presentation [.ppt] from Rational Publishing Engine?

Nirmal Jha (238) | asked Mar 30 '21, 1:46 p.m.

Is it possible to generate a presentation [.ppt] from Rational Publishing Engine?

2 answers

permanent link
Bartosz Chrabski (3.3k12648) | answered Mar 30 '21, 1:51 p.m.
Hi Nirmal,

You are able to generate Word, HTML, PDF, Excel, XML. PowerPoint is not supported.

Nirmal Jha commented Mar 30 '21, 2:08 p.m.

Thank for responding Bartosz, I am aware that PowerPoint is not directly supported.  

Is there a workaround, could we possibly use the xsl-fo [.fo] output to generate one? 
Do you know if this will work and if there are any articles that provide the relevant details to do so. 

Bartosz Chrabski commented Mar 30 '21, 5:39 p.m.

I have not seen anything that would be reasonable to use for XSL-FO and PPT.

You can copy objects from Word to PPT but it is still manual work.

Nirmal Jha commented Mar 31 '21, 1:28 p.m.

Thank you for your response Bartosz

permanent link
Subramanya Prasad Pilar (4.6k14) | answered Mar 30 '21, 11:00 p.m.
Hi Nirmal,
As you already know, this is not directly supported. Instead of converting from XSL FO to PPT, you can also try copy/pasting contents from RPE's Word output to Powerpoint slide and save the PPT (through VBA macro). You should be able to run that macro through RPE.
These links may help:

Nirmal Jha commented Mar 31 '21, 2:32 p.m.

Hi Subramanya,

Thank you for your response, can you direct me to where I may be able to find information on how a macro can be added to a RPE Template.
I am aware of adding JavaScript code [generally inside a Container element]. Is there a similar element for adding VBA code.

Nirmal Jha commented Mar 31 '21, 4:46 p.m.

Hi Subramanya, 

I was able to figure out how to add a macro while generating a word output from a RPE Template, however when this macro is invoked via RPE, it results in an error "Can't run specified Macro" . However, this macro runs in MS Word when invoked on open word document. Below is the log. Is this something that you are aware of? 

Starting Word ...
CRRPE1064I Starting Word ...
Loading document ...
CRRPE1064I Loading document ...
Running macro ...
CRRPE1064I Running macro ...
Error running macro. Error: -2147352573 - Can't run the specified macro
CRRPE1064I Error running macro. Error: -2147352573 - Can't run the specified macro
Macro execution finished
CRRPE1064I Macro execution finished
CRRPE1064I Document generation finished in 3 seconds. 
CRRPE1022I The process was completed in 3.453 seconds. 

Subramanya Prasad Pilar commented Mar 31 '21, 10:26 p.m.
1. You should have MS Word installed on the same machine where Document Builder or RPE is running. (I suppose you have Word installed)
2. Have you set the extension for Word output as .docx? If so, you should change the extension for Word output to.doc or .docm.

Nirmal Jha commented Apr 01 '21, 9:02 a.m.

I tried both output extensions, however the error persists. Please let me know if there are any next steps that may be tried.  

Subramanya Prasad Pilar commented Apr 01 '21, 10:53 a.m.
Make sure you have added the macros in the stylesheet file and not in You can confirm by opening the stylesheet (that is configured to be used by Word output), double click the "ThisDocument" entry from the outline. You should see the macro from your file.
You can also open the Word output generated by RPE and check if it contains the macro that you are trying to run.

Your answer

Register or to post your answer.