It's all about the answers!

Ask a question

RTC batch file hangs and does not exit


GURVINDER SOKHI (731125) | asked Mar 25, 9:34 a.m.

We have a problem when running a batch file with RTC command. The batch file runs fine how it fails to exit at the end from the dos prompt.

Example syntax of batch file below:
set "lscmLoc=C:\Program Files\IBM\Rational\RTC\6.0.6.1\jazz\scmtools\eclipse\lscm.bat"
call "%lscmLoc%" version
exit

The above batch file runs fine on dos prompt , however it does not exit and hangs on dos prompt after successfully giving output from the "version" command as shown below. Is this a bug? any workarounds ?

H:\>"C:\Program Files\IBM\Rational\RTC\6.0.6.1\jazz\scmtools\eclipse\lscm.bat" version
Build Id: RTC-CLIENT-I20190326-1753
Version: 6.0.6.1

2 answers



permanent link
GURVINDER SOKHI (731125) | answered Mar 25, 11:23 a.m.

Hi Raplh

I am using v6.0.6.1.

Irrespective if RTC install is located under "Program Files" or not the same problem persists.

When you say it works for you , which version of RTC are you using ?

I have logged a ticket with IBM support and they at able to reproduce this issue with v6.0.5 and this might be a defect, waiting official confirmation from IBM support.


Comments
Ralph Schoon commented Mar 25, 12:03 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I can read and figured from your post that you used 6.0.6.1, even if you did not mention it. I used my 6.0.6.1. I just changed my path in your script. Initially I thought the script syntax was incorrect. Does not seem to make a difference. Windows scripting is weird.

If you already have filed a case with support, why am I spending my time?

GURVINDER SOKHI commented Mar 25, 12:25 p.m.

Thanks for your time. I wanted to reach out on jazz.net to see if other have experienced similar issue.

IBM support have suggested to use path to scm.exe and that has fixed my issue. However I am not sure if there are any repercussions of using scm.exe in a batch file ?


permanent link
Ralph Schoon (58.2k23642) | answered Mar 25, 10:51 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER


This works for me. I never install anything Jazz into "Program Files", not sure if that contributes. 


Comments
GURVINDER SOKHI commented Mar 25, 11:23 a.m.

Hi Raplh

I am using v6.0.6.1.

Irrespective if RTC install is located under "Program Files" or not the same problem persists.

When you say it works for you , which version of RTC are you using ?

I have logged a ticket with IBM support and they at able to reproduce this issue with v6.0.5 and this might be a defect, waiting official confirmation from IBM support.

Your answer


Register or to post your answer.