It's all about the answers!

Ask a question

ID CRRRW7556E The application cannot connect to the server

Sean F (1.3k243149) | asked Mar 12 '21, 8:42 a.m.
edited Mar 12 '21, 8:53 a.m.
I have installed 702 standalone trial version on Win 10

I am getting the error in the title after logging in and attempting to edit any piece of data in any project. The error also happens randomly while browsing the database

The application hangs and is unusable once the error appears.

If i leave it and come back later and log in again sometimes I can do a little more work but then the error normally reappears quite quickly

Rebooting the server makes the error go away but it comes back quickly.

I have previously run many versions of 6.0.x and also 7.0.1 without any problems

Has anybody else experienced these issues with 702 standalone server

I do not have access to technical support or I would open a case

I have tried restarting the server and restarting the machine

I have tried using Firefox and Edge and error is the same on both browsers

Sometimes the application just hangs with an eggtimer for several minutes and the application then completes the action successfully or throws the error..

The full error text is below

ID CRRRW7556E  The application cannot connect to the server. There might be a problem with your network connection or the server might not be available. Check your computer's network connection. Ask your administrator to check the status of the server.
Timeout exceeded
_6@https://localhost:9443/rm/web/_js/?include=G~&etag=CECaaVsO9sL_en_US&_proxyURL=%2Frm&ss=S52jZ&locale=en-us:2602:14 _6@https://localhost:9443/rm/web/_js/?include=G~&etag=CECaaVsO9sL_en_US&_proxyURL=%2Frm&ss=S52jZ&locale=en-us:2611:4 _8@https://localhost:9443/rm/web/_js/?include=G~&etag=CECaaVsO9sL_en_US&_proxyURL=%2Frm&ss=S52jZ&locale=en-us:5407:11

URL: https://localhost:9443/rm/resources/BI_Zs8ZsoG-EeunscV1YWmFig

james wetzel commented Mar 15 '21, 1:01 p.m.

We have intermittent issues with not being able to connect to the db (not sure when it started or 7.0.1; continues with 7.0.2).   It seems to be a transient condition as every time we are unable to connect a page refresh clears the issue and completes the original request.

Sean F commented Mar 16 '21, 9:52 a.m.
Thanks James

Yes, I am getting the error again after reinstalling back to 701

Kind of strange since i am running a standalone server with small data on a hi spec machine

The highest version I had run before that was 606 so I never used 6061

I never experienced these glitches before when running 606 and older

The logs folder is empty on my install

C:\Program Files\IBM\JazzTeamServer\server\logs

3 answers

permanent link
Ralph Schoon (63.1k33646) | answered Mar 23 '21, 2:39 p.m.
edited Mar 23 '21, 2:48 p.m.
I said it before and I say it again DO NOT INSTALL INTO PROGRAM FILES, IF YOU DON'T WANT PROBLEMS. I know that it is the default. It is idiotic to have it as a default as that, but I can not change that.

If you start the server, it tells you, that you have to start it (from the command line) as administrator, to get the logs folder populated. You haven't. It is shown in the console and easy to overlook. This is also an indicator for potenial problems. As there are special rules operating on Program Files, Windows takes the liberty of limiting what you can do. e.g. you can not create folders. I have seen multiple attempts of users failing to get the servers even running here. Windows also gives a crap if you are logged in as an administrator. You still have to open a cmd "as administrator" from the special options in the UI to really get admin rights. Similar to linux sudo -i. Unless you do that - every time - there is no guarantee, your server does not die. So install into c:\jazz\ or C:\elm or some other useful named folder.

If you never start as administrator, search on the server folder for ccm.log. it is in the server/liberty\wlp\..... substructure, if I remember correctly.

If the client can not connect (also installed in Program Files?) there are some logs in one of the subfolders in the eclipse folder. I am OOO, maybe answer tomorrow. Otherwise the log of eclipse is located in the Eclipse workspace folder. It sits in an invisible folder named .metadata.

permanent link
Sean F (1.3k243149) | answered Mar 22 '21, 9:58 a.m.
I am getting 701 frequently hanging just like 702

The error is slightly different and says

The server has taken too long to respond.
ID CRRRW7557E  The application has been waiting for some time for the server to respond to a request.

I don't know if it is the same problem as the OP but behaviour is similar

Ralph Schoon commented Mar 22 '21, 11:37 a.m.

Sean, I am running systems like the one you describe on my laptop for years. This includes 7.0, 7.0.1, 7.0.2. I currently have at least and the 7.0.x versions installed at least as one instance. 

I do not get the se errors. All the errors you mention hint that there is something fishy going on with the network or the application. Either the messages do not reach the application, or the application is very slow or unresponsive.

I have no idea what it could be. Do you have some virus scanners and other malware detection tools installed, that might interfere? 

Check the logs, if there are many errors in them. Check the diagnostics page and run a diagnostic when the system starts failing.

A colleague using a MAC just today reported similar issues.

Sean F commented Mar 23 '21, 12:08 p.m.
Thanks Ralph

I re-installed back to 702 and the problem has gone away again (but last time it came back after a few days)

>>Check the logs, if there are many errors in them

Can you tell me where are the logs?

This folder is empty on my install

C:\Program Files\IBM\JazzTeamServer\server\logs

permanent link
Sean F (1.3k243149) | answered Mar 12 '21, 10:50 a.m.
I solved this by the cunning method of uninstalling and reinstalling everything

I went back to 701 for mitigation but it was probably a localised installation corruption rather than something to do with 702

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.