It's all about the answers!

Ask a question

How do you export Primary Text from DNG using RPE?


Janet Charbonneau (851438) | asked Jan 25, 3:22 p.m.
Hi, we are running Jazz 6.0.4 and I am using RPE 6.0.5.  I am trying to export the primary text from DNG artifacts that have data in it that looks like it has come from a Word document.  I am using the DNG Text data source and the rich text body (dataSource/artifact/content/text/richTextBody/div) for output.  I am getting output from my other data elements, but am not getting any output for the rich text body.  How do you output Primary Text using RPE?  Here is what my template looks like:

One answer



permanent link
Subramanya Prasad Pilar (4.4k14) | answered Jan 26, 12:52 a.m.
edited Jan 27, 12:26 a.m.
dataSource/artifact/content/text/richTextBody/div should print the rich text content of DNG Text artifacts. I dont see any issue with the Cell selected in the screenshot.
Can you mention what is the URI set for "DNG Text" data source (URI property of Data Source Configuration element)? Also, what are the data filters on queries $3 and $7?
Note that dataSource/artifact/content/text/richTextBody/div can be used for Text artifact urls -  rm/publish/text?resourceURI=<uuid> and not for rm/publish/resources?resourceURI=<uuid>


Comments
Janet Charbonneau commented Jan 26, 4:38 p.m.

The URI for DNG Text is https://servername/rdm/publish/resources/*.  The filter for query $3 is title == "projectname" so it pulls only artifacts for a particular project.  The query for $7 is _value == "Text" where it is pulling only artifacts with the format of "Text" since the ones that I am trying to export are Text format.  I am getting data with the first two cells, just not any from the last cell.


Subramanya Prasad Pilar commented Jan 27, 12:27 a.m.

Please try /publish/text/ instead of /publish/resources/.


Janet Charbonneau commented Jan 28, 4:27 p.m.
My output using /publish/resources gives me output without the primary text: 

After I changed it to /publish/text it dies and I am getting the following error (NOTE: to protect customer, our server name has been changed in this screenshot to servername):


Do you have any other ideas on that else I can try?  Thanks!

Your answer


Register or to post your answer.