It's all about the answers!

Ask a question

RPE report for DNG Module works on one machine and not another

Deborah Thomas (1112) | asked Jul 09 '20, 3:28 p.m.
RPE 2.1.2
 A user is using a template that reads a DNG Module and reports on the requirements artifacts associated with that module.
They sent me the RPE template because they were getting the errors listed below.
Once I was given access to the DNG source data, I loaded the RPE template and selected Configure and Generate Document, entered the URL for the module, with username and password, set the protocol to Auto and the document produced correctly.
I am confused about why a template would work on my computer and not the user's.
Here are the errors the user sees when they try to Configure and Generate Document:

CRRPE0282I Document Studio has started.

CRRPE0016I The template C:\Program
Files\IBM\Rational\Publishing Engine\templates\DNG\DNG_Module.dta is loading.
CRRPE0017I The template C:\Program
Files\IBM\Rational\Publishing Engine\templates\DNG\DNG_Module.dta loaded.
CRRPE1020I The document will be published locally
CRRPE1064I Starting run...
CRRPE3612W Credentials provided for data source module
but the authentication method is not explicitly specified. This may result in
CRRPE1064I Processing document template 1 of 1.
CRRPE1064I Data source module using URL data removed for privacy
CRRPE3107I Downloading data from data removed for privacy

CRRPE1064I Error in engine

Auto: connection to data removed for privacy failed. None of the known protocols succeeded.

CRRPE1064I Aborting engine execution...

CRRPE1064I 0 publishing commands are processed. 0 publishing commands remain to be processed.

CRRPE3097I The document template is processed. If there are no more templates to process, output files are being written.

CRRPE1064I Document generation finished in 3 seconds.

CRRPE3603I Enable the Core Debug Mode for RPE to receive additional information on errors.

CRRPE1022I The process was completed in 3.683 seconds.

CRRPE1023E The document could not be generated.

2 answers

permanent link
Hugh Lippincott (199) | answered Jul 09 '20, 5:18 p.m.

As you probably know, RPE's interface with DNG is complex and dependent on many configuration aspects being correct.

It appears that the user is missing some access permission: "data removed for privacy".

Is this template installed in DNG and being run from within DNG, or being run from the RPE interface?
Running from RPE makes many aspects more configurable (some automatically), so if you run from RPE and they from DNG then you are effectively running different reports as the DNG interface to the RPE engine is quite limited.

Deborah Thomas commented Jul 09 '20, 5:25 p.m.
The report is executed from RPE, not the DNG GUI (I have not tackled that yet)
data removed for privacy is my notation for the actual URL data, not the error message.
The user has administrator privileges on the DNG source.  They can access the artifact from the DNG interface and can also enter the URL directly into a browser and access the XML data.  I have only read privileges to the DNG artifact, yet I can configure and generate the document from RPE on my computer.  This is why the error is so confusing to us.

Hugh Lippincott commented Jul 09 '20, 5:49 p.m.

-RPE only needs read access to DNG, so you and user are = there

-I don't see any failure to find or access the report's output style sheet, but  RPE can  be obscure about error reporting.
-I'd start by reviewing the user's configuration of RPE (dsx file) to ensure it's properly configured.
There is a deeper and more complex level of debugging possible, but usually not needed until you need to debug RPE templates installed in DNG:
Do you have access to the DNG & RPE log files on the server, and can you turn on extra debugging output?

Deborah Thomas commented Jul 10 '20, 10:12 a.m.
I am not sure where to find the RPE log files.
I have checked the .dsx configuration and all is the same on my .dsx as the other user.
I tried the extra debugging, but did not see any change in the console window.
Maybe there is more in the RPE log files?

permanent link
Subramanya Prasad Pilar (4.6k16) | answered Jul 10 '20, 1:04 a.m.
Can you try after setting "Authentication Type" for the data source OAuth? You may need to set it to "Basic" if JTS is configured with JAS.

Deborah Thomas commented Jul 10 '20, 10:14 a.m.
When I run the RPE template, I leave the Authentication Type blank and I get results.
I am accessing the exact same artifact in DNG as the other user.
I asked the user to try that and when that did not work, we tried each of the Authentication Types and none of them worked.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.