It's all about the answers!

Ask a question

Unable to checkin target folder of a Maven project from Eclipse Neon

Chidambaram L (23414287) | asked Jul 01 '20, 6:00 a.m.

 I am using Eclipse Neon (Version 4.6.3). Installed RTC plugins of RTC client.

Shared the project before mvn install. hence target directory was not available when Sharing the project.
after running mvn install, target folder is created. This new folder is not appearing in pending changes view. I have checked the .jazzignore file & also ignore files from the Eclipse --> Preferences

How to checkin target folder of a maven repository.

Shashikant Padur commented Jul 01 '20, 6:06 a.m.

Is the new folder under the shared project? or is at the root of the sandbox?

Accepted answer

permanent link
Shashikant Padur (4.2k27) | answered Jul 03 '20, 1:13 a.m.
edited Jul 03 '20, 1:14 a.m.

I tried it with the latest version of the RTC and see the same behavior. This is a defect and I have raised the following work item:

By the way, the scm cli shows the correct output using "scm show status" command. It lists the newly added folder and files as unresolved.
Chidambaram L selected this answer as the correct answer

Chidambaram L commented Jul 03 '20, 2:01 a.m.

Thanks Shashi.

Will use cli. Though on an ideal Continuous Integration scenario with Maven, target folder would not be checked-in.
In my case, I need to check the binary into RTC. I will change the name of target folder using maven tasks & try to check-in.

Shashikant Padur commented Jul 03 '20, 2:37 a.m.
The scenario I tried may have been a little different than yours.
In my scenario, I had a sandbox and I shared a folder under the sandbox to a component. Now I shared another folder from outside of the sandbox (using cli). This causes an out of sync scenario and any modifications under the new shared folder does not show up.
Do you see any out of sync in the pending changes view?

2 other answers

permanent link
Chidambaram L (23414287) | answered Jul 01 '20, 6:10 a.m.
edited Jul 01 '20, 6:13 a.m.
It is a root folder like src folder.


Shashikant Padur commented Jul 01 '20, 6:57 a.m.
It does not seem to be the root folder of the sandbox. It is a folder under your project. Did you refresh your sandbox? There is a refresh icon in the toolbar of the Pending Changes view. From the dropdown, select "Refresh Sandboxes and Remote Changes".

If the folder is indeed at the root of the sandbox, then you need to share that folder to the component.

Ralph Schoon commented Jul 01 '20, 8:55 a.m. | edited Jul 01 '20, 8:55 a.m.
Is there anything in the target folder that gets checked in? Empty folders do not show and you don't want to check in a compilation product anyway.

RTC does not check in folder, it only check in the changes to files.

permanent link
Chidambaram L (23414287) | answered Jul 01 '20, 9:07 a.m.

 @spadur"Refresh Sandboxes and Remote Changes" was tried. But that folder did not show up in "Pending Changes" View.

@rschoon, folder has come content, apart from ignore list.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.