It's all about the answers!

Ask a question

Compatibility ELM 7.0 / 7.0.1


Steffen Koller (11) | asked May 22, 9:29 a.m.
HI,

based upon the experiance, that AM Module 6.0.6.1  is not compatible with RTS 6.0.6  I want to address the following question:

If I install ELM version 7.0 - and there are already two version of version 7.0.1 -
is the final version 7.0.1 compatible?  So can I install this as a patch WITHOUT the need to migrate the data?


Note: Normally I would expect Version handling like:
V.R.U.B

V represents the main version and indicated compatibility
R represents a release, that means functionality changed/added.
U: represent the level of bugfix. No change in any documented function, just make it properly working!
B: Build nummer

Bit IBM forces me to update and migrate everyhting to be able to use 6.0.6.1 against 6.0.6.
( And in fact, the migration fail, beacuse it is not trivially done)
Now I just want to avoid same trouble.


IN case version 7.0.1 is NOT a bugfix, but also a full incompatible change, I may wait till I have a more mature  ELM  version.

Thank you.

2 answers



permanent link
Bartosz Chrabski (2.5k11935) | answered May 22, 10:04 a.m.

 Hi Steffen,


7.0.1 is not a patch for 7.0. It is completely new version and You will have to go throught the upgrading process.

The same was with 6.0.6 and 6.0.6.1. Patches are called iFixes and you installed them without upgrading the database.

Hope it is answering you question.


permanent link
Steffen Koller (11) | answered May 22, 10:44 a.m.
Hi Bartosz,

thank you for bringing me up with that IBM version philosophy.

OK, then I will check for iFixes of version 7.0.   and also I try to get some information about
the differences between 7.0 and 7.0.1....

(Just to add: I am especially interested in  7.0 because there the AM module was merged with the CCM and I want to check the OSLC capabilities)

Many thanks!!

Steffen

Your answer


Register or to post your answer.