It's all about the answers!

Ask a question

RTC Client connection error - version compatibility

Nick Keller (2314) | asked May 12 '20, 1:15 p.m.
I'm trying to deliver some code changes to a legacy application, but am getting an error message connecting to RTC server.

An attempt to deliver fails with the following error message:

CRJAZ6022E Cannot log into the following server: ''.
CRJAZ0099E An HTTP error occurred when this URL was being accessed: Error details: Received fatal alert: handshake_failure.

I'm interpreting this as the RTC server no longer accepts connections from a 5.0.2 client.

Two questions:
1) Is my interpretation correct?

2) Any way to deliver a code change w/o updating the RTC client?  This is a very old system, I've downloaded the 6.0.6 RTC client, as 6.0.6 is recommended for the eclipse version (4.4) in use. I configured the 6.0.6 client as a repo in InstallationManager, but when I try to install the 6.0.6 RTC client it complains about needed a newer version of InstallationManager. But it's not clear to me how to update Installation Manager. In InstallationManagers "Updates" there is a "Search for InstallationManager updates" button, but the list of install options does not include  any InstallationManager updates.  Do I have to download a repo of an updated InstallationManager?

FWIW: I inherited this scenario, it seems that all the repos are local copies, not connections to remote repos.

Ralph Schoon commented May 12 '20, 2:58 p.m.
The help provides an upgrade guide.

You do not want to do a server upgrade. You want to make sure to use a client that is compatible. As mentioned below, find out the server version and get a compatible client.

Make sure to use a latest and greates updated Java version with the client (and the server possibly).

Bartosz Chrabski commented May 12 '20, 3:03 p.m.

Only issue can be that 5.0.x is out of support since 2019-04-30. 

Ralph Schoon commented May 12 '20, 3:05 p.m. | edited May 12 '20, 3:05 p.m.
Yes. Support might be gone. Still I would expect support to come up with suggestions.
By the way, BACK UP your Eclipse Workspace and sandbox before you try anything with another client. Make a copy of all that data.

Accepted answer

permanent link
Kevin Ramer (4.5k9185200) | answered May 12 '20, 3:09 p.m.
edited May 12 '20, 3:12 p.m.
No one thinks of TLS configuration on the server immediately upon seeing "handshake failure"  This is not an issue with ssl trust or certificate lifetime.  Those concerns are noted separately by the connecting client.  

As it turns out my group hosts the noted server and it is configured to provide TLSv1.2 protocol ONLY

If the above does not provide a solution contact DevIT
Nick Keller selected this answer as the correct answer

Nick Keller commented May 12 '20, 4:47 p.m.
Hi Kevin - Odd, clicking or cut/pasting the link above gave me black page, but opening the KC directly && searchign for TLSv1.2 gave me the page...

Per the page - adding to eclipse.ini solved the problem.

Thanks very much!

3 other answers

permanent link
Bartosz Chrabski (3.4k22849) | answered May 12 '20, 1:25 p.m.

Hi Nick,

1) Yes, you right. The version of your client is not compatible with your server version. If the server is 5.0.2 then you should use 5.0.2 client too.

2) You can upload the code using command line client, windows shell or eclipse but they need to be compatible with the server version.

Nick Keller commented May 12 '20, 1:36 p.m.

Hi Bartosz - I'm using the 5.0.2 client., so it would seem that the server that was upgraded and no longer supports connections from a 5.0.2 client.

Do you know how I can tell what version the RTC server is at?

Nick Keller commented May 12 '20, 1:53 p.m.

So google tells me to use Help-About on the RTC server web page...
Help-About tells me that the server is at verison 5.0.2:
(Odd, I can't seem to attach a picture. Get rpompted for pick-file, and pick 38KB jpg file, but then dialog disappears.)
Picture indicates:
About the Rational Jazz Team Server
Version 5.0.2
Client Access License Types assigned to Nicholas Keller:
Rational Team Concert Versions 5.0

So it would seem that the Server version and Client version are in sync.

Any ideas why I get the version error message when trying to deliver?

Thanks in advance

Henryk Tomczyk commented May 12 '20, 2:29 p.m.


In the right upper corner after logon, You will have "?" icon, you cliclk it and after thet you select About this application.

Version number should be there.

Bartosz Chrabski commented May 12 '20, 2:33 p.m.


Nick Keller commented May 12 '20, 3:05 p.m.

Hi Henry - I was able to get the version (see post above yours) just was nto able to attache image here for some reason...
The Server is 5.0.2...


Google tells me this might be a certificate issue, so I tried importing the certificate using keytool,  Alas, no luck.

Turned on and looked at the output to try and get better idea where failed.  All seems 'normal', except for right above where the ClientHello  section starts there is a line "SSLv3 protocol was requested but was not enabled", followed by a "Worker-1, called close()" message about closing the socket.

So at this point I'm pretty sure the Server and Client are on compatible versions, but that there might be some SSL issue.

FWIW: This environment worked fine about two months ago, just recently logged back in to back port some code changes.

Any pointers would be appreciated... 

Bartosz Chrabski commented May 12 '20, 3:10 p.m.


As Ralph suggested, I think it will require support or some professional services. 

showing 5 of 6 show 1 more comments

permanent link
Ralph Schoon (63.2k33646) | answered May 12 '20, 2:54 p.m.
An RTC Client can only ever connect to a server with a version number equal or +1 major version higher than the client.
So, if your server is 5.0.2, you client must be 5.0.2 or 4.x up to 5.0.2.

The error says:

Error details: Received fatal alert: handshake_failure.

I don't think this is an error related to the client and server version. I believe version mismatch errors look different. Just because the first page a CCM client acccesses is the version compatibility page does not mean that is the error. The page might not be accessible for other reasons e.g. on the server.

My best guess would be that the server runs on an ancient Java Version that has revoked certificates or someting like that. Maybe some other app server or client connection related problem.

Contact support and provide them with the logs they require to get this fixed.

permanent link
Nick Keller (2314) | answered May 12 '20, 4:47 p.m.
Per the page - adding to eclipse.ini solved the problem.

Thanks very much!


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.