It's all about the answers!

Ask a question

RTC REST API + special char & (&)


Olivier ROSET (50221) | asked Feb 17 '20, 8:58 a.m.
 hello,

With RTC REST api, when I try to call it with a "&" in some of his arguments, I get not results.

The parameter who contains the "&" special char in his value is encoded in the url, so the "&" is replaced by %26
and still no results at all.

Any idea on how to encode this special char in the argument of the url ? 
Short sample of the url call : 

  <server base url>/rpt/repository/workitem?fields=workitem/workItem[projectArea/name='Le projet' and (category/id="/Unassigned/Contributions+hors+XXXX%2FRecrutement+%26+comp%E9tences%2FR%26C+380%2FR%26C+380+-+nouveau+profil/"].... 

Accepted answer


permanent link
Ralph Schoon (63.3k33646) | answered Feb 18 '20, 2:11 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I think this is a general HTTP/REST related issue. Have you tried Google(OSLC encoding special characters)? I found several interesting hits.

Olivier ROSET selected this answer as the correct answer

One other answer



permanent link
Olivier ROSET (50221) | answered Apr 02 '20, 5:12 a.m.

 The solution. :) Sorry for bothering you with this basic url encoding stuff. : )





Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.