It's all about the answers!

Ask a question

Token license usage reports - not bearing useful fruit

Norman Dignard (356684157) | asked Aug 20 '19, 3:46 p.m.

 Our env Jazz CLM 605, using libery/oracle backend configured to use our token license server.  We have a Jazz production and testbed  deployment both using the same license server.

We currenty have 1000 tokens in our pool and for some reason about 2am we get rtc-dev license denials.
To clarify, one of our projects is using several accounts to perform a migration of code from their legacy system into JAZZ.  These accounts only have a RTC-DEV license. During their run on an import process, which typically starts around 10pm , at around 2AM their jobs fail as they get license denials due to no licenses available . We are a typical 9-5 office so night time usage of Jazz very minimal.

In looking at the Jazz admin license reports on both our servers , the numbers don't add up for the same timespan.
On our prod system:
All licenses maxes a about 150 with 1 license denial
RTC- Dev only max - about 120 with 1 license denial

Our testbed
All licenses maxes a about 60 with 110 license denial
RTC- Dev only max - about 60 with 110 license denials

Based on the above we've way under our 1000 token usage.

I also tried the Rational License Management and Reporting tool which is basically useless in trying to figure out why we're getting denials. One report from is Concurent Peak denials for the same timespan shows 154 for RTC.    

Any idea/suggestions how to approach this?


One answer

permanent link
Kate Draper (11) | answered Aug 26 '19, 11:32 p.m.

 Hi Norman- Sorry to hear that you are having problems with the LKS Administration and Reporting tool (ART). I would be more than happy to help you investigate this issue further. I have detailed some information below that would be helpful so we can begin investigating.

- Versions of the RLKS and ART/Agent you are currently using
- Licensing, ART, and agent logs
- Peak usage report along with a user based report for 24 hours when there is a denial

Norman Dignard commented Aug 27 '19, 8:38 a.m.

We since upgraded lic server to 816 from 815 and a new ART 8161 from 8155.

We can connect to db2 in ART but get error creating a server - server does not appear to be running on local host. 
Looking at the ART startup log complains of an invalid cert. Same error in 8155.

Extract from ART console.log.
[WARNING ] CWWKS9590W: The TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384 requested cipher suite appears to have [integrity, confidentiality, establishTrustInTarget, strong, noexport, tls] association options that do not match the specified [integrity, confidentiality, establishTrustInTarget, noexport, tls] supported options and the [integrity, confidentiality] required options.

Also have 
[WARNING ] SRVE9967W: The manifest class path pdq.jar, xml-apis.jar. pdq.jar
 can not be found in jar file .........  or its parent.
[err] SLF4J: The requested version 1.6 by your slf4j binding is not compatible with [1.5.5, 1.5.6]

Kate Draper commented Aug 27 '19, 10:20 a.m.

Hi Norman- thank you for providing the additional info. Good to know you are using the latest version of ART ( What brand and version of a browser are you currently using? 

Norman Dignard commented Aug 29 '19, 9:27 a.m.

I've tried FF, chrome and  IE from a windows box. Same results.

Norman Dignard commented Aug 30 '19, 7:37 a.m.

I've managed to address at least one issue.  After 816 upgrade, could not create a server/agent config in ART.  I did note an error in the rclagent log complaining about an invalid license. We used the same lic file from 815.  The problem stemmed from an error in merging multiple lic files in 815.  One license file appeared to have been appended twice.  815 appeared not to care but in 816, we could not save the server/agent parameters in ART.  After fixing the licence file issue, I was able to save.  I'm surprised that this was not picked up in the flexlm logs as opposed to the agent logs.

In any event now that everything appears to be running and configured,   I still have a problem in creating a report. It just does not save. 

Any ideas why?
the only thing i'm seeing in the agent log file is:
ERROR 2019-08-30T07:09:41,938 [Default Executor-thread-5][][268] - Name is set to null or it is empty : null

at the time I'm trying to save the new report.

Kate Draper commented Aug 30 '19, 1:42 p.m.

Hi Norman, I am not quite sure why you would be experiencing this issue without more details. One thing I would suggest is to try naming the report then saving. If that doesn't work, I suggest you reach out to the support team so we can take a deeper look into your log files and licensing issues. You can submit a support case here: I will reach out to the team and keep track of it as well.

Your answer

Register or to post your answer.