It's all about the answers!

Ask a question

Jenkins and RTC Integration

Jose C (1112) | asked Jul 24 '19, 3:20 p.m.
edited Jul 26 '19, 2:06 a.m.

Hello. I am trying to setup a Pipeline to work with RTC, but Jenkins (RTC Pool SCM) is not tracking change-sets properly. I don't know whether it is a mistake from my side or not.

When I change a line of code or add a new class file and then follow: Pending Changes → Check-in all → Deliver. Nothing happens. The log keep saying No changes.

"Rational Team Concert (RTC) Polling Log
Started on Jul 24, 2019 8:42:44 PM
RTC : checking for changes...
Determining if there are incoming changes using the build toolkit
Checking incoming changes for "admin build"
Reusing facade for D:\Program Files\IBM\RTC-BuildSystem-Toolkit-Win64-6.0\jazz\buildsystem\buildtoolkit
RTC : No changes detected
Done. Took 0.19 sec
No changes"

Example of Pipeline code:
"pipeline {
    agent any
    triggers { pollSCM('/1 * * *') }
    stages {
        stage ("Stage One"){
            steps {
               checkout([$class: 'RTCScm', avoidUsingToolkit: false, buildType: [buildDefinition: 'admin build', customizedSnapshotName: '', value: 'buildDefinition'], overrideGlobal: false, timeout: 480])

Sridevi Sangaiah commented Jul 25 '19, 1:32 a.m.
Can you open the build workspace in the pending changes view in the EWM(RTC) client and check if you see any incoming changes?
To open the workspace in the pending changes view in the eclipse client:
1. Login to the repository as the build user who owns the build workspace
2. Navigate to "Team Artifacts" view
3. Expand "My Repository Workspace"
4. Right click on the build workspace
5. Select "Show>Pending Changes"

Jose C commented Jul 25 '19, 2:12 a.m.

Thank you for your answer. I will try it when I get home.

Let me see if I understood. I should make a change, then check-in and deliver. Afterwards I should follow your steps, right?

EWM means the eclipse IDE? 

Obs: I am doing it locally, I have only the admin user. 

Jose C commented Jul 25 '19, 5:22 p.m.

Hello, I am sorry for my late feedback.  Yes, I can see the Pending Changes in my build workspace.

Jose C commented Jul 26 '19, 10:57 a.m. | edited Jul 26 '19, 10:58 a.m.

It was solved. I don't know if it is a mistake from my side or an issue but I have added: credentialsId: 'credential', overrideGlobal: false, serverURI: 'https://localhost:9443/ccm'

And it is polling now.

Ralph Schoon commented Jul 26 '19, 12:38 p.m. | edited Jul 26 '19, 12:50 p.m.
I was unable to convert this to an answer. Some thoughts:
  1.  Override the Global settings should not be necessary, the user connecting needs to have a license allowing to build and permissions to access the build data.
  2. 'https://localhost:9443/ccm' is an URI that shoud never show up in any production setup. Always use full qualified host names. Localhost is not even a good idea for a test environment.

Accepted answer

permanent link
Ralph Schoon (63.2k33646) | answered Jul 26 '19, 12:35 p.m.
Seems to have been a configuration error. See

Ralph Schoon selected this answer as the correct answer

One other answer

permanent link
Ralph Schoon (63.2k33646) | answered Jul 25 '19, 1:21 a.m.
edited Jul 25 '19, 1:23 a.m.

Jose C commented Jul 25 '19, 2:08 a.m.

I saw some articles like those and I followed some of them to setup the environment. But I didn't find a clear article regarding pipelines.

I tried everything available in the network to make it work. But as I said before, I don't know if it is a fault from my side. It's my first time with Rtc and pipelines. I've done it before with other kind of source management. 

Can you confirm to me that it is supported, at least? 

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.