It's all about the answers!

Ask a question

How to set URL encoding to WAS Liberty server?


Natarajan Thirumeni (25812) | asked Jan 31, 4:04 p.m.
How do we force WAS Liberty server to support URL encoding to UTF-8? We needed it because we have some user who's password contains non-ASCII characters (such as the character "123£").

The user can create a password which contain a  contains non-ASCII characters, however attempting to login into CLM serer, results into an error message (invalid user name or password). How do we fix this issue?

Accepted answer


permanent link
Natarajan Thirumeni (25812) | answered Jan 31, 4:08 p.m.
edited Jan 31, 4:09 p.m.
An easy workaround is that, to change password and use one without non-ASCII characters.

In some cases, you're forced to use non-ASCII characters in the password and in that case, you go to set
override encoding on the Liberty server side. Here are steps:
  1. Go to C:\<BM>\JazzTeamServer\server\ <wbr> liberty\servers\<clm> (Windows path, can be modified to Unix too)
  2. Find jvm.option file
  3. Back up jvm.option file
  4. In the original jvm.option file, add -Dclient.encoding.override=UTF-8
  5. Save file
  6. And restart Liberty server.

You should be able to login into CLM server who's user name & password contain a non-ASCII chars such as 123£

Ralph Schoon selected this answer as the correct answer

Comments
Simon Eickel commented Jul 03, 1:11 a.m.

Just in addition:

When you are using JAS for authentication, it is enough to change the jvm.options in JAS. You don't need to change it in all appropriate application profiles.

If jvm.options file does not exist - easily create it. Websphere Liberty will use it automatically 

Your answer


Register or to post your answer.