It's all about the answers!

Ask a question

RPE - Using JSON on DNG


David Reilly (6940) | asked Sep 19 '18, 1:04 p.m.
edited Sep 19 '18, 1:39 p.m.

Hi there, 


I'm noticing something troubling after posting new Rational Publishing Engine templates to DOORS. I initialized the new templates, and then when I went to test them out, I received the following error message:

ID CRRRW7552E  The specified artifact cannot be found in the global configuration.

Unable to load....

Error 404: Not Found
Propagated exception; original message [NotFoundException: com.ibm.rdm.internal/summaryDesignExport.json;rev=null;cs=null;uri=https://localhost.com/rm/storage/com.ibm.rdm.internal/summaryDesignExport.json]

Requirements Management/6.0.2

Has anyone seen this error message or have any suggestions for how to fix this behavior? We're using RDNG v6.0.2 iFix15.

Thanks,
David


Comments
David Reilly commented Sep 19 '18, 1:27 p.m. | edited Sep 19 '18, 1:39 p.m.

Updated main question. 

Accepted answer


permanent link
Fariz Saracevic (904613) | answered Sep 20 '18, 2:42 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

I appreciate for the feedback David! 


We will be updating RPE Knowledge Center in the next release to ensure this information clear.
Thanks,

David Reilly selected this answer as the correct answer

Comments
David Reilly commented Sep 21 '18, 12:08 p.m.

Thanks Fariz! Hopefully that saves anyone from going down the same path I did. 


For anyone who may be in the same boat, I got out of this jam by calling a VBA macro to parse the JSON results after the document has been generated. This seems to work for the time being.

Regards,
David 

One other answer



permanent link
David Reilly (6940) | answered Sep 19 '18, 1:41 p.m.

Should have known...



Why is this not a big bold disclaimer on the RPE help guide? Confusing.


Your answer


Register or to post your answer.