It's all about the answers!

Ask a question

How to resolve Connection timed out error for RTC build engine while connecting with local Jenkins

Yogesh Goyal (1112) | asked Sep 12 '18, 11:43 a.m.
edited Sep 12 '18, 12:13 p.m.

 Hello Friends,

I have installed RTC as well as Jenkins on my local machine. I tried to connect RTC in Jenkins via its ccm url and it is successful. Now I have created a build engine (Hudson/Jenkins) in RTC and given the jenkins url as http://<IP of my machin>:8080 (without /jenkins in url), but I am getting connection timeout error. However same url http://<IP>:8080 is working in browser and I am able to open jenkins.I have already tried below solution, but none is working. Please help me to resolve this error asap. 
(1) Given localhost instead of IP. But then its giving error localhost cannot resolve
(2) Added "/" one slash at the end or url
(3) Added /jenkins in the url (even though I am able to access jenkins without /jenkins in url), just to give try
(4) changed timeout setting form 30 to 1000 (or even 5000)
(5) Unchecked as well as checked Validate Certificate/URL
(6) Checked as well as unchecked authentication required etc
Below is the version details of Jenkins and RTC
Jenkin - ver 2.121.3
RTC - Version 5.0.2, Build ID RTC-I20141031-0926
Local Machine - Windows10
Error I am facing - Connection test requested. Connecting to:
Exception: Connection timed out (Connection timed out)
Test connection FAILED!
When I hover to yellow trangle, it says "Hudson/Jenkins server may not be present or running". While jenkins is up and running.
After this solution, I need to configure a Job in Jenkins which just pull the source code (not build/compile) at local. So if possible, please help me with the configuration of this "Pull only" job on jenkins too. I have already installed RTC build tookkit in Jenkin. Thanks in advance.

One answer

permanent link
Ralph Schoon (63.2k33646) | answered Sep 13 '18, 3:09 a.m.
edited Sep 13 '18, 3:10 a.m.

 The connection test needs to succeed first for all I know. The setup depends on a mutual ability to connect between Jenkins and the Jazz Build Engine created for Jenkins. If this is not done/ does not succeed you can not use the integration. 

This might be some kind of network issue. Since it is unclear what integration version you are trying to set up and what install guidance you followed I don't think your additional information is helpful.

Yogesh Goyal commented Sep 13 '18, 10:51 a.m. | edited Sep 13 '18, 10:52 a.m.

Hi. I tried to give as much information as possible in my post. If still something missing, please let me know what information you need.

I have installed RTC and Jenkins both on my local machine. Jenkins to RTC Test connection is successful. But RTC jenkins build engine to Jenkins test connection failed (timeout) for the correct jenkins url. Just now I have installed tomcat too on my local machine and installed jenkins inside that tomcat so that I can try http://<IP of my machine>:8080/jenkins/ URL. But still RTC test connection failed for jenkins url. Please help.

Ralph Schoon commented Sep 13 '18, 11:00 a.m.

Yogesh Goyal commented Sep 13 '18, 1:52 p.m.

Might be I am noob, but I still not getting Ralph that what I have missed to inform in my post. I told that both RTC and Jenkins are installed on my local machine (so there should be no network issue). I told the version number, I told the various troubleshooting steps I tried by going through various threads on this forum. RTC hudson/jenkins build engine giving timeout error when trying to do test connection "First time" itself. 

Ralph Schoon commented Sep 14 '18, 9:13 a.m. | edited Sep 14 '18, 9:17 a.m.

Yogesh, there are different Jenkins integrations available. Which one do you use? Pointer to the download and install instructions you follow? So there is a lack of context. I also overlooked some information since there is no structure.

I have done this some years ago, the most important point was that this is a catch 22. You need to be able to connect to Jenkins to create the Build definition in RTC. 

Just for your information, I just moved to a new laptop with Windows 10 and I have connection problems between my browser and the RTC SDK. I should not, but I have them. SSL seems to be something I have problems with. Newer Java Versions reject certain protocols and you might not even realize that. This might contribute as well. I have no clue.

Maybe someone else can help.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.