It's all about the answers!

Ask a question

I have a stream that somehow got itself set as its own flow target -- RTC won't let me delete it

Tammy Parker (36) | asked Aug 02 '18, 2:39 p.m.
edited Aug 16 '18, 1:06 p.m. by David Lafreniere (4.8k7)

I have a stream that originally had a flow target to another stream
I was asked to remove this flow target
When I did that, the flow target somehow got updated to be itself
I am worried that this is going to cause a horrible problem and want to remove this cycle -- will this cause an endless loop of 'flowing' and blow up the stream ?
I believe I need an admin's help to fix this...
( this is RTC client/server 5.0.1 )

One answer

permanent link
Geoffrey Clemm (30.1k33035) | answered Aug 05 '18, 5:43 p.m.

Although strange, it is almost certainly harmless.   There are no algorithms that recurse down the flow relations (these relations are just used to configure the Pending Changes view).  For example, you can have stream A be a flow target of stream B, and stream B be a flow target of stream A, so there is nothing problematic with cyclic flow relations.

What happens when you try to delete this flow, using the Eclipse stream editor?

Tammy Parker commented Aug 06 '18, 6:07 p.m. | edited Aug 16 '18, 1:04 p.m.

HI Geoffrey -- Thanks for the reply and for letting me know that it would not have caused a catastrophe to have a stream flow into itself.

I had tried to delete the flow target via the RTC native windows Client ( version  5.0.1 ) by opening up the stream definition and deleting the flow target.  I did not try to remove it via Eclipse.  From the RTC Client, It would act like it worked; I would do a save and then see it back again after re-opening. After trying this several times with no luck, I got some help from our RTC admin for this repository and he had success using his administrator credentials to remove the unwanted flow target from the stream.

Geoffrey Clemm commented Aug 16 '18, 10:23 p.m.

If this happens again, and you have the time, please submit a defect ... it either should work, or you should get some kind of error message making it clear why this wasn't allowed (such as you not having permission to make this change to that stream).

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.