It's all about the answers!

Ask a question

Proxy server configuration for RTC

JAISHANKAR SIDDAGANGAPPA (111) | asked Oct 12 '09, 4:37 p.m.
I am using the steps provided in to configure a Proxy server for RTC.

I completed the following steps.

1. Installed Cygwin.
2. Created a self signed certificate.
3. Downloaded squid.3.0 and extracted it to C:\

Now, when I run command to compile squid, I get the following error

$ ./configure --enable-ssl -prefix=/usr/local/squid --with-filedescriptors=2048
./configure: line 15: $'\r': command not found
./configure: line 26: syntax error near unexpected token `$'in\r''
'/configure: line 26: ` case `(set -o) 2>/dev/null` in

Please advise.

Thank you

One answer

permanent link
Anuerin Diaz (4112517) | answered Oct 13 '09, 3:18 a.m.
First off, this is a Cygwin+Squid problem and not RTC.

With that out of the way, the problem is because your configure script has a DOS line terminator that is not readable by Unix tools. I would hazard an assumption that this line ending was introduced when you extracted it using Winzip or when the file was opened and saved using a Windows-based text editor.

You have two options:

1) use the d2u application to convert the line endings of the configure script to Unix-style. Open a cygwin terminal and navigate to where the configure script is located then execute d2u configure

If the line endings was introduced by your archive decompressor the other files may be affected. Which brings us to:

2) Use the cygwin tar command to decompress the archive. The command is tar zxvf


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.