It's all about the answers!

Ask a question

Server Rename -- Failure on Datawarehouse

Sterling Ferguson-II (1.6k9283269) | asked May 01 '18, 6:31 a.m.

CLM 604 - Distributed

Oracle 11.x




We have a test environment that we have 604 installed as a copy of live. We ran a server rename on the applications and ServerRenameStatus all work...great. However, the ReportBuilder fails testing as the data from the warehouse still points to the original URLs. IBM has offered the following:


- Question: Very likely during the rename the data warehouse was offline. Did you clone the warehouse and changed the JDBC connection strings for all apps, user and password prior to launching the rename?

- You should restore data warehouse and rename each app data in the data warehouse with its own repotools command. So:

./ -renameURIInWarehouse <wbr> jts/ logFile=repotools-jts_ <wbr> renameURIInWarehouse.log noPrompt
https:/original.server. <wbr> com/jts newURI=https://new. <wbr>

(repeat the commane for each application)


Nothing was "offline" and is this a normal procedure for DW after a server rename? We have followed the exact steps listed in the Server Rename area. Although there isn't much information on the DW except:


Log in to the Jazz Team Server at https:// new host : port /jts/ <wbr> serverRenameStatus. Logging in starts the renaming process. The CLM applications will synchronize with the Jazz Team Server to apply the URL mappings and update their data warehouse data. This process generally takes about 5 minutes for a small data set and up to 30 minutes or more for a large data set. When the rename is complete, you can verify the rename and take any corrective action that is necessary. See Verifying URLs and links after a server rename for details.


Should we add the above step (per application) as part of our future server rename test environment setup, or should we have been doing something different? Is this a "Post Server Rename" step once the system is back online?





2 answers

permanent link
Jon Agnew (8123) | answered May 01 '18, 1:36 p.m.
edited May 01 '18, 1:38 p.m.

During a normal server rename the data warehouse should have been updated, and though I've never tried it with the data warehouse offline I would expect it to report an error in that case.

Hopefully before the rename you updated both the database and data warehouse locations for all applications as described in so that your rename affected the staging rather than the production data warehouse.

If you examine the various application logs (e.g. ccm.log) you should be able to find the start and end of the rename. Somewhere between those lines you should see a connection to the data warehouse.
2018-04-26 16:06:59,749 [    Default Executor-thread-84]  INFO itory.service.mapping.internal.ServerRenameService  - CRJAZ2326I A mapping event file is present in the configuration directory. Starting server rename...
2018-04-26 19:02:31,379 []  INFO tawarehouse.service.internal.RemoteDatabaseService  - CRRTC8039I The connection to the following data warehouse database was successful:
 DB Product Name: DB2/LINUXX8664
  DB Product Version: SQL10059
  DB URL: //;password=xxxxxxxx;
2018-04-26 20:09:48,735 []  INFO sitory.service.mapping.internal.ServerRenameHelper  - CRJAZ2327I Server rename completed successfully for the application in 14568830 ms.

But also double-check which data warehouse Report Builder is currently using. For Report Builder you need to update the database warehouse location to point at your staging database after the rest of the rename has completed:

permanent link
Daniel Barbour (250323) | answered May 01 '18, 11:53 a.m.
edited May 01 '18, 11:59 a.m.

Though server renames are infrequent for me - I experimented in a sandbox I have for 6.0.5 which includes the reporting apps (rs, lqe, dcc) along with jts, rm, qm, ccm, gc, and ldx.

I followed the standard instructions for server rename (including first unregistering ldx and lqe) and did not perform the special repotools command you described above (".../ -renameURIInWarehouse..").  In my case, Report Builder still worked properly for a report I have that lists test case results for a project that uses the Data Warehouse.  All links were updated.

Since I did not encounter the problem you observed I am uncertain if it will help, but you might consider going the the Data Collection Component and re-run all data collection jobs (but, before doing so, go to the 'Delta Load Configuration' page and set the Load Type to 'Full Load' for all resource groups).


P.S. - I cannot find the -renameURIInWarehouse repotools command option in the IBM Help References.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.