It's all about the answers!

Ask a question

Upgrade RTC from 4.0.3 to 6.0.4


Satish Narayanachar (96413) | asked Apr 11 '18, 7:17 a.m.

Hi All,

We are planning to upgrade RTC from current version 4.0.3 to latest version.

Below is our setup

JTS version :- 4.0.3 ; Server :- Windows 2008 R2 ; DB :- SQL server 2008

I know to upgrade from 4.0.x version we have to move to 5.x first and then to 6.x version

My question is

1. Since the DB version (SQL 2008) is not supported in 5.X version, can we upgrade RTC to 5.X using the upgrade commands and then upgrade SQL from 2008 to latest version(SQL 2014)?

or

Do we have to upgrade to latest 4.0.7 version which supports SQL 2008 & SQL 2012 and then upgrade RTC from 4.0.7 to 5.x and then from 5.x to 6.x version?

What do you suggest on this?

Thanks,

Satish

2 answers



permanent link
Salman Shaikh (23211266) | answered Apr 12 '18, 9:41 a.m.
Both are right ways but second one is more appropriate regards to stability and process.
Activity 1: Upgrade DB to latest Version- This will make sure your DB is up to date and is working fine with 4.0.3.
Activity 2: Upgrade from 4.0.3 to 5.0.2
Activity 3: Upgrade from 5.0.2 to 6.0.x
Run JTS Setup and verify that everything is working fine.

permanent link
Don Yang (7.5k2195130) | answered Apr 11 '18, 7:50 p.m.

Hi, Satish

Option2 would be a better way.

Upgrade to v4.0.7 first could have its own advantage because the process is much less problematic and you can easily test whether it has any problem or not before you go to 5.0.2. If you use RM, RM is separated from JTS in v5.0.2 and this CLM upgrade could be more complex and you may want to have less change in v5.0.2(keep SQL 2012 in v502). Also since 502 does not claim supporting SQL 2008, it may mean option 2 is the only choice.

Your answer


Register or to post your answer.