It's all about the answers!

Ask a question

How to add an internal image in a html widget


Luiz Almeida (23014876) | asked Mar 07 '18, 3:49 p.m.
edited Mar 07 '18, 3:52 p.m.

Hi community,


I'd like to insert an image in a widget in the dashboard.

I don't know if I am wrong, but I added the image following the steps:

1. In RTC Client I opened a project area
2. In the Link tab I added an image in the Attachements section.
3. In the dashboard I added an HTML widget
4. Now, in the widget I need to inform the URL of the image attached, but I do not know what is the complete URL.

Does anybody can help me?

Thanks in advance.

3 answers



permanent link
Rohini Kumar (92231) | answered Mar 08 '18, 4:36 a.m.

Hi Luiz,

 You can use alternate way i.e you can use open source BIRT  to show image in RTC widgets.


Comments
Luiz Almeida commented Mar 08 '18, 9:20 a.m.

Thank you, Amruta...I still think that there's more easy way to do that.


permanent link
Matt Muller (58312462) | answered Mar 08 '18, 8:56 a.m.
edited Mar 08 '18, 8:58 a.m.

Hi Luiz,

I've just done this.. if you right click select "properties" on the attachment to get the Address URL

In your HTML widget - insert Image enter URL.

Works for me


Comments
Luiz Almeida commented Mar 08 '18, 9:19 a.m.

Hi Matt,

Where exactly you click to see the "properties" option? I can't see in my screen.
See it.
Project Area Link Tab


Matt Muller commented Mar 09 '18, 3:29 a.m.

Hi Sorry,

I used a "Work Item" in web to add the Attachment and then got the properties from that.

Rather than to attach in Eclipse and directly into the Project - please you got it.

You do have another option to investigate - using web you can add in a Process Description.

Regards

Matt


permanent link
Luiz Almeida (23014876) | answered Mar 08 '18, 2:12 p.m.

I got it.

After to add the image in the attachements (Link tab), I setted the URL path to

https://<hostname>:9443/ccm/service/com.ibm.team.workitem.common.internal.model.IImageContentService/processattachment/_8jFp4Px0EeeJGOazHJag2A/<imagem_name>, where "8jFp4Px0EeeJGOazHJag2A" is the identifier of the project area.

It worked, but I had luck to discover the correct path. I did not find a easy way to discover that.

Your answer


Register or to post your answer.