It's all about the answers!

Ask a question

Java SDK 8.0.5.10 supported?


Vlastimil Cudek (111) | asked Mar 06 '18, 9:23 a.m.

 Hi,
 is Java SDK 8.0.5.10 supported by Rational Team Concert v6.0.5 on WebSphere 9 or not?
I read a lot of info about Java 1.7 support, System requirements shows Java SDK 8.0.4.10 but no support for 8.0.4.11.


Thanks for info,
 Vlastimil


Comments
Salman Shaikh commented May 08 '18, 7:12 a.m. | edited May 08 '18, 3:46 p.m.
@dnong I have installed WAS 9.0.0.7 which requires latest version of Java SDK 8.0.5.11 but CLM doesn't support this version. When i am trying to update/ modify java to 8.0.4.10 it is giving following error.


Salman Shaikh commented May 08 '18, 7:14 a.m.


Salman Shaikh commented May 08 '18, 7:14 a.m.


Donald Nong commented May 09 '18, 3:03 a.m.

I don't think WAS 9.0.0.7 "requires" JDK 8.0.5.11. Also, the way that you tried to update JDK 8.0.4.10 makes no sense to me.

3 answers



permanent link
Donald Nong (14.4k213) | answered Mar 06 '18, 7:16 p.m.

If it is not listed in the system requirements as supported, it is not supported. Any reason you want to go with JDK 8.0.5.10, rather than the supported version 8.0.4.7 and 8.0.4.10 with WAS 9.0.0.4?


Comments
Vlastimil Cudek commented Mar 07 '18, 5:03 a.m.

That answer is useless for me.

 The System requirements document for Rational team Concert shows Java SDK 8.0.4.7 and 8.0.4.10 supported, while version 8.0.4.11 unsupported. But the future releases are shown as supported in general as I understand.
We are installing Rational Team Concert now, when the Java SDK 8.0.5.10 is available for WebSphere 9. In case of Java SDK, it is always recommended to use the latest one, because so many security and stability problems in Java SDK.
 Unfortunately Rational Team Concert reports: "CRJAZ2152W Jazz encountered an error when attempting to determine the version of your Java virtual machine"
 If it is necessary to go with only listed versions of Java, hmm, we can use this old Java SDK.


Donald Nong commented Mar 07 '18, 5:29 p.m.

It is not nice to use the word "useless" when someone tries to offer help.

The system requirement does not state "future release" for the server component. Even it does, it will mean the version after 8.0.4.11, as it usually means "fix pack release", which refers to the 4th number in the version number.
https://www-01.ibm.com/support/docview.wss?uid=swg27008656

Both JDK 8.0.4.11 and 8.0.5.0 came out around the same time, when it was quite late at the development stage of RTC 6.0.5. I can only speculate that it was too late to add support (particular for 8.0.5.x), or the testing revealed some problems that could not be fixed in time.

If security vulnerability is the big concern, you should contact IBM Support and see how it should be addressed.


permanent link
sreenath v (534) | answered May 09 '18, 1:40 a.m.

 i had same issue while installing ibm clm 6.0.5. My WAS configuration was 8.5.5.10.

So i installed IBM Java SDK 8.0.3.0. And now it worked for me


permanent link
Vlastimil Cudek (111) | answered May 09 '18, 5:04 p.m.
edited May 09 '18, 5:07 p.m.

Running Rational Team Concert v6.0.5 on WebSphere 9.0.0.6 with Java SDK 8.0.5.10 without any problems.
The latest iFix (004) is the key, as it "removes" message about unsupported JDK version
No problems so far in test environment, but performance looks not so good as we expected. Due more performance problem discussions with Java 1.8 (more discussions in forum), we will stay with WebSphere 8.5.5.x and Java SDK 1.7 on production system and upgrade to 6.0.4 version only.

Your answer


Register or to post your answer.