It's all about the answers!

Ask a question

What causes an error message like this: "Unable to resolve the planning attribute '' as work item attribute ''" in RTC when bring up a plan?

Kim Williams (56135) | asked Feb 16 '18, 12:49 p.m.

I am using RTC 6.0.4, on iFix 006. In the Web configuration editor (as opposed to hand editing the XML) I added 2 new attributes to my work items and mapped them as plan attributes.  I tested to ensure that I could create a plan, and see the attributes in a plan, and then I moved the new process template to production.  The architecture is such that child project areas point to a parent project area.  It is the parent project area that I updated. 

When one of the project areas tried to bring up their existing plans while pointing to the newly updated parent project area, the get this message: "(error: Unable to resolve the planning attribute '' as work item attribute ''.) "

I tried opening the plan of another project area pointing to the same parent, and the plan opens successfully. I added a column to the plan using the new plan attribute.  That also worked successfully.

I went into the code to verify that the mapping is correct, and everything looks good, which seems to be supported by the fact that I was able to open plans and add the attribute successfully in one of the project areas. 

Is there anything else that would throw this error, other than an incorrectly mapped attribute?

Donald Nong commented Feb 18 '18, 7:34 p.m.

Just to clarify, are you saying that after you made all the changes in the parent/master project area, you could open plans in one child project area, but not in the other?

Don Yang commented Feb 19 '18, 12:20 a.m.

You can check with source code if the below entry exists:

implementation="" name="xxxx"
<parameters> parameter key="attribute"

in parent or child project

Donald Nong commented Feb 21 '18, 12:57 a.m.

I believe the easiest way to restore the inheritance of the child project is to completely remove the content in the Process Configuration Source tab using the RTC Eclipse client.

Kim Williams commented Feb 21 '18, 7:06 a.m.

Yes, that would be the easiest, I agree.  And I was going down that route until I saw that they had broken inheritance on their Plan Views.  They have done extensive work on their plan views, and I can't just delete their XML until I can figure out a way to preserve their Plan Views.  Any idea how to retain their plan views?   

Ralph Schoon commented Feb 21 '18, 7:48 a.m. | edited Feb 21 '18, 7:48 a.m.

You can try to go through the configuration-data XML blocks and identify the ones that have something to do with work items and delete the whole block until the override is gone. If you look into the section ID's tell you what that belongs to. E.g. id="" usually means work items.

id="id="" would be agile planning.

Take this with a grain of salt: I have never tried that. You probably want to make sure you know the latest version of the XML in the history to be able to go back, or save the whole content, before beginning surgery.

Ralph Schoon commented Feb 21 '18, 8:02 a.m.

Also, their planning customization will likely refer to the work item configuration, which they changed which might break the plan customization regardless what you do.

Use the final flag in the sharing project area to prevent overriding in the future.

Kim Williams commented Feb 21 '18, 8:11 a.m.

Ralph - I don't think that they intentionally broke the inheritance, so they will not know what they have added.  I would like to find out if they changed anything in the work items.  Is there a way that I can compare their child XML with the parent (sharing project)  XML to see the differences?

Ralph Schoon commented Feb 21 '18, 8:28 a.m.

The differences are what they have in their overwritten project area XML. You can compare that using your eyes and brain. I am not aware of any other method. You could try to copy paste both XML's into local files and use compare tools e.g. beyond compare. I think there is almost no chance that will help you, though.

showing 5 of 8 show 3 more comments

One answer

permanent link
Kim Williams (56135) | answered Feb 19 '18, 5:56 a.m.

Donald Nong - yes, that is correct.  Over the weekend I found out that the child project where I can't open the plans (get the error) has broken inheritance from the parent in several areas (work items - "Types and Attributes", "Editor Presentations", and in Planning - Plan Types, Plan View Elements, and Plan Views).  It seems like it has something to do with that, but not exactly sure what.  I haven't been able to reproduce it yet.  Note: We do not want the child to have broken inheritance and have to fix that.  I thought I had a solution to fix it, but now realize I do not because of broken inheritance in the planning part.  My solution only took care of the broken inheritance in work items. 

 Don  Yang-  Thanks.  It does exist in the parent, but not in either child.  This is what I would expect.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.