It's all about the answers!

Ask a question

DNG 6.0.5 - Cannot initialize reports

Oana Capatana (23520) | asked Jan 24 '18, 1:53 a.m.
edited Apr 25 '20, 11:58 a.m. by Fariz Saracevic (919613)


I have installed DNG 6.0.5 and I am trying to run a custom report for a module. I have uploaded my RPE template but I cannot issue the reinitializing request of the publishing service.

My user has Rational DOORS Next Generation - Analyst license set and ALL repository permissions. When I try to reinitialize the publishing service using:

I get the following message:
CRRRS6534E Current user does not have the required administrator privileges

I have done this numerous times in previous DNG versions and never encountered this issue before.

Accepted answer

permanent link
Robert Huet (23113584) | answered Feb 07 '18, 3:23 p.m.

 Passing on answer from IBM Support:

The behavior you're seeing is actually working as designed starting as in DNG 6.0.4. The method for reinitializing the Publish Service via URL no longer works and was replaced by the procedure below:

1. Go to

2. Click Debug.

3. Click Publish Services (under Services) in the left side.

4. Click the "Initialize Service" button.

Unfortunately, the new procedure was not added to the knowledge center until 6.0.5 due to the defects below:

Defect 116312: Initializing publish service through /rm/publish/initialize no longer works (doc update):

Defect 434497: Initializing publish service through /rm/publish/initialize no longer works (doc update):

This is why you only see the new procedure in the 4th step of the "Manually importing custom document-style report templates for requirements management" section in the 6.0.5 documentation:

6.0.4: Making document-style reports available to viewers:

6.0.5: Making document-style reports available to viewers: <o:p> </o:p>

Oana Capatana selected this answer as the correct answer

2 other answers

permanent link
Penchala suman (461425) | answered Jan 24 '18, 2:23 a.m.

Please try in different browser, even I had similar issue in RDNG 6.0.4. When I try to initialize in chrome had permission issue and then tried in IE it works for me. <o:p> </o:p>

Oana Capatana commented Jan 24 '18, 2:33 a.m.

 Thanks for your answer.

I have tried in Chrome, FF and IE but unfortunately I get the same result everywhere

permanent link
Oana Capatana (23520) | answered Jan 24 '18, 7:32 a.m.

 It worked after resetting the repository permissions a few times combined with some server restarts

Robert Huet commented Feb 07 '18, 1:21 p.m.

 We are having this same problem after our 6.0.4 upgrade.  I'm able to get "initialize" to work in IE but not in Chrome.  One of my colleagues tried in IE but it did not work for him.

We have LDAP integration with Active Directory, and our Repository Permissions correctly show us as JazzAdmins in the UI.

How did you reset the repository permissions to fix this issue?

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.