It's all about the answers!

Ask a question

In RPE, how do I traverse a link from RTC to an artifact in a configuration aware DNG project area?


Bob 3 (1482067) | asked Dec 31 '17, 6:07 p.m.
edited Jan 06 '18, 7:41 p.m. by Geoffrey Clemm (30.1k33035)

I have a follow-up question to https://jazz.net/forum/questions/123676/


The problem is that the RTC schema, as far as I can tell, only provides the base artifact URL with no configuration context for linked DNG artifacts. That is:

Provided by RTC schema: 

Needed to successfully navigate the link to a configuration-aware project area:


Comments
Bob 3 commented Jan 03 '18, 12:11 p.m.

 Bump


Geoffrey Clemm commented Jan 06 '18, 7:44 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This question was posted as an "answer" to a related question.   To avoid confusion, please post related questions as separate questions, not as "answers".

One answer



permanent link
Kumaraswamy Gowda (39115) | answered Jan 01 '18, 12:44 a.m.

You need to add configuration information in the document specification. See video https://www.youtube.com/watch?v=A_tnclbU564 on how to perform these action.

If the starting point is RTC or DNG or RQM and any traceability links to it will use the configuration you set at the first place as you inherit configuration in DSC element.


Comments
Bob 3 commented Jan 01 '18, 12:11 p.m. | edited Jan 06 '18, 7:43 p.m.

Thanks for your response, Kumar!

My template only has one visible data source in its document specification: an RTC data source. The reason for this is because my template is designed to publish a single RTC work item and then explore its links. Can you explain how to define a configuration context for an RTC data source in RPE Launcher?
(When I follow the steps outlined in the YouTube video to which you linked, the process fails at the OSLC Service Discovery Selection Dialog.) I'm using RPE 6.0.5.


Kumaraswamy Gowda commented Jan 03 '18, 12:25 p.m. | edited Jan 06 '18, 7:43 p.m.

Hi Bob,

There are no versions for CCM work items. Only SCM has versions and snapshots. We're working on how to report on such scenarios. We'll get back asap.

In the mean time, could you try the following?

In RPE Studio, for DNG data source, set configuration required to blank so that this data source is visible in doc specification in Launcher. For DNG data source, set the Configuration-Context (C-C) as in the video I shared.
BTW, do not set C-C for RTC WI data source.

Thanks,
Kumar


Kumaraswamy Gowda commented Jan 04 '18, 5:30 a.m. | edited Jan 06 '18, 7:43 p.m.

The solution again is same as in the video https://www.youtube.com/watch?v=A_tnclbU564 . You need to select configuration while configuring data source for RTC. The same configuration will be used by DNG. More details below.

The GC for RTC project area is set as in the below screenshot.



Template
The template screenshot below shows how to get link from RTC Work item to DNG requirement.

This condition is added to get "implements requirement" from workitem/auditableLink/name
name == "com.ibm.team.workitem.linktype.implementsRequirement"

The below is to get REST URL from workitem/auditableLink/targetRef/uri from DSC element configuration
uri.replace("resources/", "publish/text?resourceURI=");



Document specification
In Document specification, after configuring data source to RTC work item, you should select global configuration as in the menu option below. See video for more details.



We're able to generate document as per above.

Thanks,
Kumar


Bob 3 commented Jan 12 '18, 8:08 p.m.

Kumar, thanks for your response.

When I try to follow the steps, I encounter difficulty at the RPE Launcher step where I right click on the data source and select OSLC Configuration Selection. The wizard that follows does not allow me to proceed. What happens is it provides a default URL for root services:
And ultimately the wizard becomes caught in an infinite loop of challenging me to authenticate.
Do you have any ideas? Am I using the correct root services URL for RTC?


Bob 3 commented Jan 17 '18, 1:01 p.m.

Bump 


Bob 3 commented Mar 15 '18, 1:02 p.m.

Note: Kumar identified the solution in a different thread.

The solution is to use the Global Configuration root services, not RTC's:
Thanks, Kumar!

showing 5 of 6 show 1 more comments

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.