It's all about the answers!

Ask a question

RTC 6.x Extensibility workshop error Eclipse client launch EclipseStarter.class not found

Kevin Ingles (111) | asked Nov 14 '17, 4:44 p.m.
edited Nov 15 '17, 6:32 a.m. by Ralph Schoon (63.2k33646)

I am running the RTC 6.x Extensibility workshop from PDF RTC603ExtPoT. I am installing on Linux and use Eclipse Luna. I successfully installed RTC 6.0.4 and the Eclipse client functions perfectly until I try to Test the RTC Eclipse client launch (Sec 1.9, pp 67-69). On pg 68 when I click Debug, the client launch fails with the following error:

!ENTRY org.eclipse.equinox.launcher 4 0 2017-10-18 11:20:41.842
!MESSAGE Exception launching the Eclipse Platform:
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
        at java.lang.ClassLoader.loadClassHelper(
        at java.lang.ClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        at org.eclipse.equinox.launcher.Main.invokeFramework(
        at org.eclipse.equinox.launcher.Main.basicRun(
        at org.eclipse.equinox.launcher.Main.main(

As expected, the same error occurs when I do a client launch from the run configuration in Sec 3.3, pg 82.

Eclipse is already open, and this launch is supposed to fire up another instance of Eclipse, but fails.

I did find the org/eclipse/core/runtime/adaptor/EclipseStarter.class in the jar file org.eclipse.osgi_3.10.2.v20150203-1939.jar (in directory installs/TeamConcert/eclipse/plugins). But I have been unable to successfully load in classpath for the client launch.



Ralph Schoon commented Nov 15 '17, 3:02 a.m.

Kevin, I have not seen this issue. However, I don't understand the reference with the classpath. You should only have to run from the launch file. You should not have to add any classpath.

Kevin Ingles commented Nov 15 '17, 8:30 a.m.

Initially I open the Eclipse client with the client workspace (ClientWS). And this works fine. But when I go to Debug Configurations in eclipse (pg 67 in workshop) and click Debug I get the error. Another instance of eclipse is supposed to open, but gives the error. I followed all workshop instructions for install.

Kevin Ingles commented Nov 15 '17, 8:37 a.m.

I figured something is missing in the classpath of the launch, since it can't find the EclipseStarter class. I am running as root on Linux.

One answer

permanent link
Girish Chandra P (853246) | answered Feb 04, 10:43 a.m.

 I had the same error , Please use the Target Platform as Running Platform Default . As RTC client SDK does not have the bundle org.eclipse.equinox.concurrent(this is missing). With this I am able to resolve the error. Default Platform

Ralph Schoon commented Feb 05, 3:16 a.m.

If you do this, you can not run client SDK based extensions. 

Girish Chandra P commented Feb 19, 3:37 a.m.

I agree , to  have all the feature I  have combined both Platform in one .   Merge - Platform

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.