It's all about the answers!

Ask a question

RTC client is not working with visual studio 2017 15.3.4

Faik OZGUR (112) | asked Sep 19 '17, 1:46 a.m.
edited Oct 31 '17, 9:50 a.m. by David Lafreniere (4.8k7)

I have tried to install RTC client 6.0.4 for visual studio 2017 15.3.4. Installation has finished successfully. But Team Concert menus are not shown in Visual Studio. I cant see Source control plugin listed under Tools->Options->Source Control.

I have a Visual Studio 2015 installed on same machine. RTC Client works properly with it. 
I have also tried to install RTC client 6.0.5M4 bur tesults are the same. 

Petra Halasz commented Oct 11 '17, 9:47 a.m. | edited Oct 11 '17, 9:50 a.m.

I have the same issue with the RTC Client for Microsoft Visual Studio IDE 6.0.4 in combination with Visual Studio 2017 Version 15.4.0 (I tried both the Community Edition and a trial of the Professional Edition). The plugin was installed through IBM Installation Manager.
Neither the Team Concert menu nor the Team Concert entry under Tools->Options-> Source Control is visible.

Are there any solutions to this issue? Or am I just forgetting to set some necessary options/properties?

Manoj Panda commented Jan 22 '19, 9:24 a.m.

I do have similar issues here with CLM 6.0.6. while installing VS client , the IM does not detect 2017 VS version , but it shows and enabled VS-2010. I dont know why, Again if i go ahead with VS-2010 (infact we should not), I cant see the RTC source control plugin option in tools-source control.

3 answers

permanent link
Ralph Schoon (63.2k33646) | answered Oct 11 '17, 10:16 a.m.
edited Oct 11 '17, 10:18 a.m.

 After kicking my head trying to figure the Systems Requirements, 6.0.4 should apparently support VS 2017 so I would suggest to create a PMR with support.

I doubt that prior versions support it since they were released 2016.

permanent link
Lukas Steiger (3131626) | answered Oct 30 '17, 4:50 a.m.

 Is there a known solution for this or is there already a PMR for it?!

We just ran into this while upgrading our VS2017 Clients (15.4.x) from 6.0.3 to 6.0.4

permanent link
Faik OZGUR (112) | answered Oct 30 '17, 6:41 a.m.
edited Oct 30 '17, 6:42 a.m.

Here it is a workaround mentioned in related task of this issue. I didn't try it yet.

2. Tobias Burkhardt Oct 23, 2017 4:54 PM  
We have the same problem and have found a workaround for this:

The InstallExtensionVS2017.bat has the problem (In  C:\Program Files (x86)\IBM\Rational Team Concert Client for Microsoft Visual Studio IDE\bin)

@echo off
REM #***********
REM # Licensed Materials - Property of IBM
REM # (c) Copyright IBM Corporation 2017. All Rights Reserved.
REM # 
REM # Note to U.S. Government Users Restricted Rights:  
REM # Use, duplication or disclosure restricted by GSA ADP Schedule 
REM # Contract with IBM Corp. 
REM #***********

for /f "delims=" %%p in ('Setup.Configuration.CS.exe instances 15.0') do (
%%p /q /a Annotation_VS2010.vsix 
%%p /q /a BuildUI.vsix 
%%p /q /a ScmUI.vsix 
%%p /q /a TeamArtifact.vsix 
%%p /q /a WorkItemUI.vsix 
goto :EOF

This file doesn't find the VSIXInstaller. If you change following line

for /f "delims=" %%p in ('Setup.Configuration.CS.exe instances 15.0') do (


for /f "delims=" %%p in ('Setup.Configuration.CS.exe instances 15') do (

it is working.

Lukas Steiger commented Oct 30 '17, 10:17 a.m.

 Thank you :-)

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.