It's all about the answers!

Ask a question

CRRGW5701E The Oauth provider properties cannot be found.


Christine Makasy (731123) | asked Jul 11 '17, 6:06 a.m.

 We have upgraded Jazz to Version 6.0.3. Due to a lot of dependencies we must still use tomcat and DB2 as database.

In LQE we reindexed all data sources.
Using the Report Builder we got the error message that data sources are not available. 
In the rs.log we can see the following error message: 

2017-07-11 09:49:26,512 [         http-nio-9443-exec-33] ERROR tion.reporting.common.restservices.BaseRestService  - CRRGW5701E The Oauth provider properties cannot be found. <o:p> </o:p>

com.ibm.team.integration.reporting.common.exceptions.OauthHandleException: CRRGW5701E The Oauth provider properties cannot be found.
at com.ibm.team.integration.reporting.data.restservices.DataSourceBaseService.getOauthProviderProperties(DataSourceBaseService.java:115)
at
com.ibm.team.integration.reporting.common.restservices.BaseRestService.service(BaseRestService.java:127)

Does anybody have an idea to resolve the problem.

Many thanks in advance.

Christine

<o:p> </o:p>

One answer



permanent link
Don Yang (7.7k21110138) | answered Jul 12 '17, 2:00 a.m.

Hi, Christine

For the similar problem, unregister and re-register reporting builder helps in several cases.
quick reference of re-register rs application is:

https://jazz.net/forum/questions/214868/report-builder-report-keeps-loading-and-never-complete-when-added-to-a-clm-dashboard-how-do-i-fix-it


Comments
steve detoro commented Oct 26 '17, 2:10 p.m. | edited Oct 27 '17, 3:42 a.m.

re-register of RS has not worked for me. neither has  un-register; un-install; remove RS directories; reinstall; re-register...

also getting this in logs-

[Webcontainer: :1 ] ERROR org.apache.jena.riot line 40 col 81  [E202] Expecting XML start or end element(s). String data “ à” not allowed Maybe a striping error

[Webcontainer: :1 ] ERROR tion.reporting.common.restservices.BaseRestService - CRRGW5701E The OAuth Provider properties cannot be found

can't identify which file it's pointing to for the  "line 40 Col 81" 

any ideas?


Ralph Schoon commented Oct 27 '17, 5:11 a.m. | edited Oct 27 '17, 5:14 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Yes, you should consider to create your own question and not post a question as a comment to an answer about a totally different error.......

Another option is to contact support.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.