It's all about the answers!

Ask a question

Unable to integrate RTC with Urban Code Build tool

anoop mc (74810170215) | asked Jun 22 '17, 2:57 a.m.

 Hi Team,

We are working on a use-case where the source code (using JKE Banking sample one) from RTC should be fetched into Urban Code Build and then deploy into WAS via Urban Code Deploy tool.

When it comes to configure the integration between RTC SCM and UCB we are facing the error where RTC scm command is not getting recognized.

Below is the configuration for RTC made in UCB.

Note: On the CLM server RTC SCM has only been extracted. We doubt some more settings has to be done to make scm command .

Any suggestions would be of great help.



2 answers

permanent link
Donald Nong (14.5k314) | answered Jun 22 '17, 5:48 a.m.

This is a more of a UCD issue than RTC issue. The scm command should be extracted and be able to be executed there - why was it extracted on the CLM server? You probably need to put the scm path into the system path as well.

anoop mc commented Jun 22 '17, 6:43 a.m.

 thanks Dona - we did not thing that way when it was rtc scm tried only on CLM server. Will try and see the other - how this goes

permanent link
anoop mc (74810170215) | answered Jun 27 '17, 10:11 a.m.


We have tried copying the RTC SCM on to UrbanCodeBuild- UCB server and extracted. Set the JAVA path in the scm.ini file. Specified path to file in the /etc/profile/

Still running the scm command from a UCB terminal is not working. Let us know if there is any additional configuration required for RTC SCM command to run.

Donald Nong commented Jun 27 '17, 10:49 p.m.

You should probably raise it in the dW Answers forum as the UCD experts are over there.

Your answer

Register or to post your answer.