It's all about the answers!

Ask a question

unable to modify the files added under RTC SCM

anoop mc (74810169214) | asked Jun 15 '17, 11:06 a.m.
edited Jun 15 '17, 11:07 a.m.

 Hi Team,

We have added an existing source files into a new RTC project area using Eclipse client
Could add those files successfully and when trying to modify some of files it is not letting (look like read-only).

Step followed:
Navigated to My Repository Workspace >> Selecting the workspace >> show Repository files option.

Tried modifying the build.xml file.

source files

3 answers

permanent link
Shashikant Padur (4.2k27) | answered Jun 15 '17, 11:58 p.m.

Did you by any chance right click on the file in the repository files view and choose "Open File"? If so, this file cannot be edited as it is showing the content of the file in the repository workspace.

anoop mc commented Jun 16 '17, 3:09 a.m.

 Yes - I did get the option to Open File as well as open local file also. 

  Open local file option let me do some editing. 


Shashikant Padur commented Jun 16 '17, 5:22 a.m.

Yes "Open Local File" allows you to edit the file in your local filesystem. Once you save the file it should show up in your "Pending Changes" view and you can deliver that change to the stream.

permanent link
Ralph Schoon (61.6k33643) | answered Jun 16 '17, 6:27 a.m.

I wouls suggest to read up on how Jazz SCM works, e.g. start with

permanent link
anoop mc (74810169214) | answered Jun 22 '17, 6:38 a.m.

Thanks for the suggestion.

Finally I got rid of the issue - This was due to - The repository workspace did not get load properly.

Steps I followed is 
1. Unloaded the current repository workspace
2. loaded one more time based on the specific component.
3. For file modification >>  navigated to Project Explorer and was able  select the file,edit and save it.
4. Navigated to Pending Changes View could see the file changes reflecting on my work-space.
5.  Adding Comment >>Check in change set >> Deliver the change set to Stream.


Your answer

Register or to post your answer.