It's all about the answers!

Ask a question

Chrome Browser: Privacy error - Your connection is not private - how to fix this error ?


0
1
Ramesh Sundararajan (1312) | asked May 02 '17, 8:57 a.m.

 I am using Chrome browser to access  https://rtp-rtc9.tivlab.raleigh.ibm.com:9443/jazz/web/projects/Marketplace#action=com.ibm.team.dashboard.viewDashboard


and i get the error : "Your connection is not Private"   - I understand this some of kind of Cert issue between Google and Symantec but what i do to fix it ? 

Accepted answer


permanent link
Kevin Ramer (4.5k6171188) | answered May 02 '17, 10:00 a.m.
edited May 02 '17, 10:54 a.m.

The URL you give is not visible to this community at large....  As one of the administrators of this and other RTC applications in the same domain here is my answer:

o  We use IBM Internal Certificate Authority
o  IBM CA Signing chain is automatically added to IBM client platform browsers

I found this post relating to Chrome and the subjectAltName extension.

Unfortunately it seems that IBM CA certificates not include the "Subject Alternate Name" extension.  I don't see that facility express or implied on the IBM CA web application.   

As far as "fixing" I would advise Firefox which is quite satisfied with the Certificate and its signing chain :-D

I opened a conversation with the IBM CA about this and the response was:

As Google Chrome browser is not supported by IBM, we suggest to do the workaround mentioned at the ticket: https://bugs.chromium.org/p/chromium/issues/detail?id=700595&desc=2 at your own risk.

However, this feature is currently not yet in the priority list for the next development sprints since this is not yet supported on IE and Firefox the official supported browsers for IBM. This will surely be implemented in time once the backlog for development will be able to accommodate the load.
[ my emphasis ]

Ramesh Sundararajan selected this answer as the correct answer

Comments
Kevin Ramer commented May 03 '17, 12:15 p.m.

New certificates with this extension are being requested and will be installed within a few days.  A post to the Forum under the "CLM Community" link you will find on the RTC login panel or on the masthead ( in the Web UI ) will be made later.

3 other answers



permanent link
Sophie Wilson (11) | answered Feb 14 '18, 7:46 p.m.

 stumble to search in the internet to look for a solution for this error finally found one that works for me ehh gonna share this to youll guys after clearing some cache and what now... i did this 

Solution No. 2 from this website those proxy thingies 
https://www.errorsolutions.tech/error/your-connection-is-not-private-chrome-error/  hopefully this gonna works as well to you'll guys cheer's.


Comments
Donald Nong commented Feb 21 '18, 1:38 a.m.

The error message is very generic, and suggesting disabling proxy doesn't help in this case. You should always check the detailed message to determine what you should do about the "your connection is not private" error.


permanent link
nathan dev (111) | answered Dec 06 '19, 12:39 p.m.
edited Dec 06 '19, 3:15 p.m.

Can it caused by antivirus and which blocking SSL certificates or internet connections your using. I have seen Avast and Bitdefender causing that issue. The same problems persist in all other browsers sometimes as well as also described here  https://techloris.com/your-connection-is-not-private/  so I think it's definitely a deeper issue than Chrome.  <style type="text/css"> &amp;amp;lt;!--td {border: 1px solid #ccc;}br {mso-data-placement:same-cell;}--&amp;amp;gt; </style>


permanent link
Gilbert Cane (11) | answered Jun 28, 2:54 a.m.

 It’s a message from your browser that informs you that the connection is not secure. This means that  your Internet connection or your computer is preventing Google Chrome or another browser from loading the page securely and privately. The “Your connection is not private” error often appears when your browser notices a problem while creating an SSL connection or can’t verify the certificate. Here are some recommendations and things to check to fix the error :

  • Check System Date and Time
  • Disable Antivirus SSL Connection
  • Clear Cookies and Cached Files
  • Reset Chrome Browser
  • Open Chrome in Incognito Mode
  • Expired SSL Certificates
  • Update Chrome Browser


Your answer


Register or to post your answer.