It's all about the answers!

Ask a question

[Need urgent help] error in 4.0.7

Daisy Huang (42113) | asked Apr 21 '17, 9:45 a.m.
edited Apr 21 '17, 12:02 p.m.

Hi there,

I used -verify to verify the integrity of the database. However I got below error:

Repositry URL is, I'm running RTC 4.0.7 with jdk 1.7 and WAS

./ -verify level=5
19:45:1619:45:05,854 [Start Level Event Dispatcher] ERROR eam.repository.common.util.ExtensionRegistryReader  - CRJAZ0201I The extension reader with plugin id "RenameVerificationURLExtensionRegistryReader@f530f53, pluginId="", extensionPointId="renameVerificationURLProvider", started=<true>" failed to add an extension to the extension point "" with the plugin id "".
19:45:16        at java.lang.J9VMInternals.verifyImpl(Native Method)
19:45:16        at java.lang.J9VMInternals.verify(
19:45:16        at java.lang.J9VMInternals.initialize(
19:45:16        at
19:45:16        at
19:45:16        at
19:45:16        at 

Actually I got the same error when I try to use -backup and -reindex.

Do you have any idea about the special instructions of the use of

Kevin Ramer commented Apr 21 '17, 10:53 a.m.

Maybe try -clean ?  If there is an ifix put down since last running repotools successfully I'd recommend the -clean.

Daisy Huang commented Apr 21 '17, 11:52 a.m.

Thank you for your answer, actually I did a migration a month ago and repotools cannot run successfully since then, but RTC works fine for users. I want to upgrade RTC now and will have to use repotools to verify the integrity of database.

Ralph Schoon commented Apr 24 '17, 2:53 a.m.

 I would be concerned if repotools stops working after a migration. Maybe there are other problems as well? I would suggest to contact support.

Accepted answer

permanent link
Daisy Huang (42113) | answered May 27 '17, 4:16 a.m.

Problem solved by using -clean!

Ralph Schoon selected this answer as the correct answer

One other answer

permanent link
Ralph Schoon (62.3k33643) | answered Apr 21 '17, 11:17 a.m.

  There is no repository URL, user or password. Did you edit the output? If not, provide the basic parameters.

Your answer

Register or to post your answer.