It's all about the answers!

Ask a question

Temporarily disabling email notifications, including those that are queued


Allen Earnest (6211736) | asked Mar 21 '17, 3:19 p.m.

Greetings All,


For administrative purposes, we need to make a batch update to a bunch of work items (thousands), and we absolutely do not want to flood our users with that much email.

I know we can temporarily disable email via the Email Settings on the JTS Admin panel, but that does not address the change events that were queued.

This question has been asked before on this forum, specifically this one seems relevant.  We followed the advice found in the technote as suggested, but it did not work when we tested it.  The emails still get sent once we re-enable Email notifications.

To help answer some obvious questions that may come up, here is our test procedure:
  1. Disable email notifications from the Email Settings on JTS Admin page
  2. Change Advanced Properties settings as per the technote (we set the Task Fixed Delay to 300 and the Default Expiration to 60)
  3. Restart JTS and CM servers so that the new changes take effect
  4. Modify the work items as needed
  5. Wait PLENTY of time for the Scrub Task to run based on setting - we use 300 seconds (5 min) and wait at least 10-15 min before proceeding to next step
  6. Enable email notifications from the Email Settings on the JTS Admin page
  7. Wait a few minutes and check to see if RTC sent any emails for the work items we changed in step 4

We are running 6.0.3 iFix003.  Does that technote still apply?

We have tried other settings with no luck.

Would appreciate any advise...  Thanks!

Accepted answer


permanent link
Donald Nong (14.4k314) | answered Mar 21 '17, 10:58 p.m.

Double check and make sure that you've made changes in the CCM Advanced Properties page, not JTS (as in /ccm/admin, not /jts/admin).

Allen Earnest selected this answer as the correct answer

Comments
Allen Earnest commented Mar 22 '17, 2:00 p.m.

That appears to have worked.  


The technote just specifies "jazz/admin".  Might help the next user if IBM could get that updated to reflect your advice.

Many thanks Donald!

2 other answers



permanent link
Allen Earnest (6211736) | answered Mar 29 '17, 9:26 a.m.

FYI, for anyone else that faces this problem...  We ended up going with an alternative solution.

We stood up a bogus SMTP server (using IIS on a Windows box).  It's easy to do.  It's a dead end SMTP server that basically dumps any email received into a folder on the filesystem.

We pointed the Rational Email Configuration to that bogus SMTP server, so that any email notifications from Rational would be sent there, instead of to the users.

After the work was done and the flood of emails was over, we switched back to our normal SMTP server.


permanent link
Ralph Schoon (60.5k33643) | answered Mar 29 '17, 9:31 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 If this is an update using the API, this can help https://jazz.net/wiki/bin/view/Main/SkipMailSaveParameter it is available since 6.0 Ifix 3. I put that into the work item command line as well.


Comments
Allen Earnest commented Mar 29 '17, 9:46 a.m.

That's pretty cool... I'll try it out... Thanks Ralph


Your answer


Register or to post your answer.