It's all about the answers!

Ask a question

CLM 6.0.3 - RQM - IE 11 - This content cannot be displayed in a frame

Aaron Cabrera (451318) | asked Mar 06 '17, 1:21 p.m.

We are testing an upgrade from CLM 6.0.2 to CLM 6.0.3.

From RQM we are unable to link a test case to a story or a requirement using Internet Explorer 11.

A window pops up and displays This content cannot be displayed in a frame

We are able to link a test case to a story or a requirement using Firefox 51 and Chrome 56.

What can we do to get it to work using IE 11?

paul chu commented Mar 07 '17, 12:36 p.m.

I don't believe there is any change in how the iframe is used in OSLC linking in 6.0.3.  Given that Chrome and FF work fine, this is probably the security settings in IE that restricted the rendering of the content.  Are all users testing with IE11 have the same problem?  Does it the IE11 browser used in testing work with 6.0.2?  Can you compare the security settings of a IE that works with 6.0.2 with the IE that doesn't work with 6.0.3?  Trying to narrow down what is different in the upgrade. 

Aaron Cabrera commented Mar 08 '17, 10:18 a.m. | edited Mar 08 '17, 10:18 a.m.

We are able to test different environments using the same browsers.  Additionally, when trying to link from RTC to RQM, the process took us through the linking wizard to select a test artifact and it saved the link in RTC.  We are not able to see the backlink to the work item in the test artifact in RQM.

Linking from RRC to RQM works as expected.

paul chu commented Mar 17 '17, 1:17 a.m.

Sorry for the late response.  I subscribed to this article but didn't get email notification on the update.  Anyway, another place to check is the friend setup between the apps.  The oslc content is sent with x-frame-option header, which would only show on the same origin, or in a white-list domain.  Does the user have the permission to access the project area of RTC and RRC?  Does linking work between RTC and RRC?  Is there any error message in the browser console?

For the link that created from RTC to RQM, I have seen it before that the backlink does not appear in RQM with configuration management enabled and the two apps are not in the same global configuration.  Or there is issue with the link index service that it delayed the update for RQM to see the new link.

Aaron Cabrera commented Mar 24 '17, 11:35 a.m.

The users do have access to both project areas in RTC and RRC and RQM.  Linking between RTC and RRC works fine.

2 answers

permanent link
Aaron Cabrera (451318) | answered Jun 27 '17, 10:12 a.m.

If you hover over the words "Clickjacking whitelist", the place where we are supposed to enter the URLs for the other applications, it specifically says "Registered JTS applications, friend servers, and whitelist (outbound) servers are trusted, and do not need to be in the list."

All of these applications are Registered JTS applications in our environment.
  In RQM, RTC and RRC are listed as friend servers.
  In RRC, RTC and RQM are listed as friend servers.
  In RTC, RRC and RQM are listed as friend servers.

According to the IBM products, these fields should be empty.

Our admin removed all the whitelist servers and set all 3 clickjacking parameters to false for all 3 applications (RTC, RRC, and RQM).  This resolved the issue in our environment.

permanent link
Kim Soederhamn (1.5k24348) | answered Apr 07 '17, 5:16 a.m.

 I'm facing a similar problem just not involving the same components but the same error message.

so far I have found that IE does have a security setting to allow or block mixed content as well as settings for content in frames. maybe you should try having a look at that? Could explain why some browsers work while IE fail. Also JTS CMM and so in their advanced properties does have x-frame options where you specifically can add an "ALLOW-FROM" to allow traffic from a distributed server. It has not solved my problem yet but this part of the advanced options has been changed from 6.0.2 to 6.0.3 so maybe it will help you.

Aaron Cabrera commented Apr 21 '17, 3:07 p.m.

We are still having issues.  I've entered a PMR and they have not been able to figure it out.  We've tried different server settings for Prevent Clickjacking, and X-Frame-Options, Clickjacking Whitelist.

I'll update this posting later when a solution is found.

mohan kumar commented Jun 23 '17, 7:19 a.m.

Hello Cabrera,

I am facing similar issue in our server did you get any update form PMR support


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.