It's all about the answers!

Ask a question

WARN eam.repository.provision.internal.ProvisionService - CRJZS0383 bundle could not be resolved.

Don Cooper (16211) | asked Mar 06 '17, 8:45 a.m.

Worked through the workshop.
Built a server side workitem extension.
Deployed my plugin on Jetty and it works as expected.
Try to deploy it on Tomcat and the provisioning service tells me it can't be resolved.

I've read all the other relevant questions and implemented their solutions when appropriate with no joy.

Verified all dependencies are available, still no joy.
Verified configurations (JRE, Eclipse version, imports, exports, etc. with other plugins that I can deploy successfully on Tomcat, still no joy.

Anybody have a rabbit up their sleeve?

One answer

permanent link
Ralph Schoon (63.2k33646) | answered Mar 06 '17, 8:52 a.m.

 There is certainly more information in the log file than the wee bit information above. That information is usually a little bit of help. Other typical issues I have seen:

1. Deployed into the wrong context (e.g. JTS and not CCM)
2. Client API in the dependencies
3. Typos in the provision profile ini (usually crashes the server)
4. Application not built right

Don Cooper commented Mar 06 '17, 9:03 a.m. | edited Mar 06 '17, 9:03 a.m.
  1. Deployed in correct context. Ccm is the context and ccm.log is where I'm seeing the warning.
  2. No client APIs. and service.
                        and service
                        and service

        Would it run on Jetty if this were the case?

  3. The provision status page shows the update site is being found, the feature is found and the plugin is found.

  4. Application not built right? Really? You don't say.

    I have an advisor deployed on the same Tomcat server. Is there something different between how to deploy an advisor and a participant?

Ralph Schoon commented Mar 06 '17, 9:13 a.m.
If I recall correctly, the Extensions workshop explains how to change the dependencies in the Feature so that would not be a dependency in the feature. although I have to admit I have skipped these steps as well.  There have been examples where users had client (e.g. in their dependencies. That works on Jetty, because the client API is available but not on Tomcat.

 I have seen rare cases, where issues with the zip files caused load problems. 
I have seen cases, where the plugin.xml was not selected as part of the build and was missing. I have seen countless questions like this one in this forum. Unless there is not more information e.g. a more detailed error message, there is pretty much nothing we can do.

Ralph Schoon commented Mar 06 '17, 9:14 a.m. | edited Mar 06 '17, 9:19 a.m.

In addition in the new version of the Extensions Workshop I have added some details about how to manage the deploy process. Unfortunately, the update is delayed due to some changes to the site.

Ralph Schoon commented Mar 06 '17, 9:25 a.m.

There is no difference between advisor and participant deployment, or any other server extension. 

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.