It's all about the answers!

Ask a question

Linux RedHat 7: JVM terminated. Exit code=160

Gidi Gal (962058) | asked Feb 20 '17, 1:29 p.m.

Hello to the forum members,

I am working on Linux RedHat 7. I am trying to run RTC client 6.0.2 installed on Eclipse 4.2.2 (p2 installation). When I try to switch to work items perspective RTC client crashes.

Related links:

I tried to copy XULRunner (and setting eclipse.ini accordingly) according to the versions proposed without much help. If anyone has proposal for a solution that worked from him, please share it here. If it includes a specific XUL version, please add it as well.

Many thanks,

2 answers

permanent link
Donald Nong (14.5k614) | answered Mar 12 '17, 11:34 p.m.

FWIW, I don't have any problems with such configuration in my own environment. I can't remember why I chose to use 32 bit, but it works anyway. Below is what I did.
1. Install Oracle Java 8 Update 121 (32 bit)
2. Install Firefox ESR 45.8 and make a link to /usr/bin/firefox.
3. Download Eclipse Java EE 4.2.2 (32 bit).
4. Modify eclipse.ini to point to the Oracle Java.
5. Start Eclipse and get some SWT errors.
6. Use yum to update the GTK libraries.
7. Start Eclipse without major errors.
8. Install RTC 6.0.2 using p2 installation.
9. Restart Eclipse and use RTC without any problems.

permanent link
Alan Sampson (93749) | answered Feb 20 '17, 1:57 p.m.

Check this technote too:
It appears to provide more specific steps on solving the XULRunner issues.

Gidi Gal commented Feb 21 '17, 4:40 a.m. | edited Feb 21 '17, 4:40 a.m.

Hello Alan,
I saw this technote before, but was not aware to the specified spectrum of xulrunner versions. I tried,,, 3.6.28. All of these crashed on the reported scenario (the second I touch the scroll bar of the dialog for changing perspective). I'm tired of testing xulrunner versions. This is the reason I opened this post, trying to find one xulrunner version that works for the guys out there.
Best regards,

Gidi Gal commented Feb 21 '17, 4:59 a.m.

Some more details on my environment:
Linux RedHat 7 64 bit, My RTC client is 32 bit, so I tried working with different 32 bit versions XULRunner. I cannot work with RTC client 64 bit due to dependencies I have to other 32 bit applications.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.