It's all about the answers!

Ask a question

Has anyone seen duplicate requirements show up in RPE with retrieving items from a view?

Jamie Berry (14013593) | asked Feb 03 '17, 8:58 a.m.

 We are using DNG 6.0.3 with RPE and are running into a strange issue.  We have an RPE template that pulls requirements from DNG using a DNG View as the data source.  Recently, this template has resulted in some of the requirements in the view being duplicated in the generated document.  After some investigation that didn't show any cause, I tried duplicating the view giving it a new name and then generated the document using the new view.  In this case, there were no duplicates.  I then tried renaming the old view and making my new view have the same name as the old one.  This time I wound up with more repetition (3 instances in some cases).  Renaming my view back to the "new" name generated with a single copy again.  I then deleted the old view and tried renaming with the old name again.  I still wound up with duplicates.  It is behaving as if there is another view hidden in the system with the original name and that RPE is pulling data from both views.  

Has anyone seen this type of behavior before, and if so, any ideas on how to fix it other than just use a new view name for the document generation?


Subramanya Prasad Pilar commented Feb 03 '17, 12:47 p.m.

Hi Jamie,
Are you generating the document though RPE (Launcher) or DNG (RRDG)? Can you check the URL used (data source URI) for document generation and try the same URL in browser (or any REST client)? If you see duplicate artifacts there as well, this is not an issue with RPE/template. Else, we need to check the template.

Donald Nong commented Feb 05 '17, 8:29 p.m.

If you suspect the view name is at play, what exactly is the view name?

Jamie Berry commented Feb 06 '17, 10:40 a.m.

Subramanya - I am generating the document through RPE Launcher.  I checked the URL in a browser and it returns a single instance of the items in the view, not duplications.  I can send you the template via email if you like.  Using a different named view(same contents) with the same template does not exhibit the issue.

Donald - the view name is 'zzDocGenSpecifications'


Jamie Berry commented Feb 06 '17, 10:59 a.m.

 I tried one more experiment...  I renamed the view in RM and tried the URL again.  It still returns values.  I also attempted a document generation and it generated with values, 11 duplicates among them.  This is with no view by the given name showing up in the User Interface.

I think it is time for  PMR with IBM to investigate the issue.

Thank you for your help,

One answer

permanent link
Fariz Saracevic (904613) | answered Feb 03 '17, 9:08 a.m.

Hi Jamie,

RPE is quite outdated. I would first upgrade RPE to 2.1.1 and test if you observer the same issue. 

Thank you.

Your answer

Register or to post your answer.