It's all about the answers!

Ask a question

Saving WI gives failure "not the most recent state"

Norman Dignard (356694176) | asked Jan 11 '17, 1:45 p.m.

A user was trying to change an wi (planed for ) but he keeps getting the same error:

Failed saving work item 19624 because it did not have the most recent state. Refresh, make additional changes, then save again.

We logged out/back in , tried different user  but get the same results every time. The WI history is also failing.

In ccm.log

2017-01-11 13:02:10,323 [http-bio-9443-exec-271 @@ 13:02 seurenm <> /ccm/service/]  WARN .team.repository.servlet.AbstractTeamServerServlet  - CRJAZ1163I ArrayIndexOutOfBoundsException processing GET request for CRJAZ1170I The request was made by user "seurenm" from "".CRJAZ1166I The stack trace hash is BE5702C5BC26713ABD5CA43EBBE55D942B9877BF.

java.lang.ArrayIndexOutOfBoundsException: Array index out of range: 1         at ........

Any Ideas on how to fix this?

One answer

permanent link
Don Yang (7.7k21114139) | answered Jan 11 '17, 5:50 p.m.

Hi, Norman

Not sure about your RTC version. You may hit one of the known defects:

Otherwise, check if reindex may help. Or a duplicate of this work item could help(if you don't really need the history of the existing one). In general, the better option for this type of issue is to contact support as it would require further investigation.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.