It's all about the answers!

Ask a question

Why don't all of my custom attibutes show up in the "attribute mapping" dialog in RTC?


Kim Williams (56134) | asked Nov 30 '16, 9:18 a.m.
I created a custom attribute on a work item in RTC and want to make it a "plan attribute".  When I go to the Attribute Mapping section and press add to bring up the "Attribute Mapping" dialog, the custom attribute is not listed.  I have done this with other custom attributes successfully.  This isn't the first time an attribute has not shown up the in the Attribute Mapping dialog.  Is there something "tricky" that needs to be done to ensure that the attribute is one that can be mapped for usage in a plan?

One answer



permanent link
Ralph Schoon (63.2k33646) | answered Nov 30 '16, 11:10 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Nov 30 '16, 11:14 a.m.
Not all attribute types are available in the attribute mapping for the plan. Not even all built in attributes are available in the plan as column, as far as I know. So for example attributes of the type large HTML might not be available (just an example, I have not checked which are and which aren't). Enumeration type attributes are usually available. So it is important to check what type the attribute has.

Comments
Kim Williams commented Dec 07 '16, 2:03 p.m.

So what I understand you to be saying is that attributes have a type, and not all of those types are available as a plan column.  That makes sense to be except that this attribute is an enumeration, and I have added other enumerations as plan attributes.  Any ideas?


Ralph Schoon commented Dec 08 '16, 4:32 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 No..........

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.