It's all about the answers!

Ask a question

Error in RTC web but ok in eclipse


sousan hussain (29654) | asked Oct 18 '16, 2:13 a.m.
Hi,
I am receiving below error while trying to open a scope change work item in RTC:
Error!
Error fetching or storing Work Item 15785 | Details: Error opening work item. CRJAZ0215E The following record was not found in the database: com.ibm.team.repository.common.model.impl.ContributorHandleImpl@bdb899bf (stateId: <unset>, itemId: [UUID _-uk9ieaveezzzzzzzzzzzw], origin: <unset>, immutable: <unset>)

However I am able to open it in eclipse without any issue.
s/w version 6.0
Template : RTC Process Template 6.1 FY15Q3

3 answers



permanent link
Mastanaiah Mannem (3712) | answered Oct 18 '16, 5:02 a.m.
this is happening for only one work item for all users. I have verified the access and ristrict level access and all are seems fine.

But some where its missing. Thanks for the prompt response.

permanent link
Mastanaiah Mannem (3712) | answered Oct 18 '16, 4:54 a.m.
 
The user data could not be retrieved. For more information, see Details.ID CRJAZ1520E
hide details
The following record was not found in the database: com.ibm.team.repository.common.model.impl.ContributorHandleImpl@aacc0bc1 (stateId: null, itemId: [UUID _-uk9ieaveezzzzzzzzzzzw], origin:  , immutable:  ) ID CRJAZ0215E
com.ibm.team.repository.common.ItemNotFoundException
com.ibm.team.repository.service.internal.RepositoryItemService.doFetchItem(RepositoryItemService.java:631)
com.ibm.team.repository.service.internal.RepositoryItemService.access$4(RepositoryItemService.java:621)
com.ibm.team.repository.service.internal.RepositoryItemService$5.run(RepositoryItemService.java:601)
com.ibm.team.repository.service.internal.rdb.RepositoryDatabase$Transaction.run(RepositoryDatabase.java:568)
com.ibm.team.repository.service.internal.rdb.RepositoryDatabase$1.run(RepositoryDatabase.java:343)
com.ibm.team.repository.service.internal.rdb.ConnectionPoolService.withNewDeferredConnection(ConnectionPoolService.java:551)
com.ibm.team.repository.service.internal.rdb.ConnectionPoolService.withCurrentDeferredConnection(ConnectionPoolService.java:569)
sun.reflect.GeneratedMethodAccessor67.invoke(Unknown Source)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
java.lang.reflect.Method.invoke(Method.java:611)
org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord.invoke(ExportProxyServiceRecord.java:361)
org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord.access$0(ExportProxyServiceRecord.java:347)
org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord$ExportedServiceInvocationHandler.invoke(ExportProxyServiceRecord.java:56)
com.sun.proxy.$Proxy127.withCurrentDeferredConnection(Unknown Source)
com.ibm.team.repository.service.internal.rdb.RepositoryDatabase.runTransaction(RepositoryDatabase.java:340)
com.ibm.team.repository.service.internal.rdb.RepositoryDatabase.runInTransaction(RepositoryDatabase.java:289)
com.ibm.team.repository.service.internal.PrimitiveTransactionService.runInTransaction(PrimitiveTransactionService.java:101)
sun.reflect.GeneratedMethodAccessor66.invoke(Unknown Source)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)



We are getting above error while accessing above URL which you mentioned by modifying with our server

Comments
Ralph Schoon commented Oct 18 '16, 4:58 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Then I must assume a user was deleted or otherwise removed. I would suggest to contact support.


permanent link
Ralph Schoon (62.9k33645) | answered Oct 18 '16, 3:02 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Oct 18 '16, 3:07 a.m.
The user record for the UUID _-uk9ieaveezzzzzzzzzzzw could not be found.

You can try to find out which record that is by going to

https:/yourserver/ccm/web#action=com.ibm.team.repository.viewUserProfile&itemId=_-uk9ieaveezzzzzzzzzzzw

If you can not fix this, consider contacting support. There should be no difference in the Eclipse and Web UI. So this is likely a bug or something odd going on..

Your answer


Register or to post your answer.