It's all about the answers!

Ask a question

Why is my custom attribute icon not appearing in my query results in Rational Team Conert?


Bill Penny (11) | asked Sep 30 '16, 8:03 a.m.
I created a custom attribute (Status Color) with 4 literals (in RTC 6.0.1).
Each literal has an icon and a name (Example -- Green dot icon with name Green).
I create a an attribute-based presentation in my work item using this attribute (which works as expected).

When I create a query to display the results of this field using this value, I only see the attribute name in the column results.

When I call other attributes (such as the default Priority attribute), I get the icon (not the name).

How can I get the icon for my custom attribute to appear in the results in the same way?

One answer



permanent link
Ralph Schoon (63.2k33646) | answered Oct 05 '16, 3:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I did just that a moment ago (process configuration stored enumeration using built in icons) and saw the following
  • I see the icon (and the literal name) in the Eclipse UI Editor presentation
  • I see the icon (and the literal name) in the Eclipse UI query result view
  • I see the icon (and the literal name) in the Web UI Editor presentation
  • I do not see the icon (but the literal name) in the Web UI query result view

I am not aware that there is any way of influencing how columns are displayed and I assume this must be an error. I would suggest to open a PMR.



Comments
1
Matt Muller commented May 23 '17, 7:02 a.m.

Hi was a PMR even opened on this?


Tadeusz Janasiewicz commented May 28 '18, 9:05 a.m.

It looks like an Enhancement was opened for this issue:

https://jazz.net/jazz/resource/itemName/com.ibm.team.workitem.WorkItem/80198

on which we are still waiting.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.