It's all about the answers!

Ask a question

Unable to link custom implemented RM artifacts with Jazz's DM (configuration enabled)


Saqib Niaz (7118) | asked Sep 08 '16, 10:51 a.m.
I have implemented a custom RM provider and it is global configuration aware. I am able to add my artifacts in Jazz's QM test cases in the context of a global configuration. When i try to link my RM artifact with DM's artifacts, it opens a Add Link dialog box, there i can select my project from Project drop down list. But when i select my project, it sends a request to my service provider's catalog then it sends a request to my project's specific service provider. But after that nothing happens. Jazz is supposed to populate the Type drop down list but it says "No selection type exists".
Can somebody help what am i missing here?
My service provider's response includes two selection dialogs, one for requirement and other for requirementCollection.

One answer



permanent link
Daniel Moul (4.5k1117) | answered Sep 09 '16, 8:06 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Have you established a global configuration context that includes RM and DM?  With Configuration Management enabled in RM and QM you can only do linking in the context of a global configuration.


Comments
Saqib Niaz commented Sep 14 '16, 4:40 a.m.

Thanks for the answer.
I have added a stream from my custom RM provider to a GlobalConfiguration Stream and added a stream from Jazz's DM to the same GC Stream. I have selected this specific global stream in the configuration context of the Jazz DM module.


Daniel Moul commented Sep 14 '16, 8:55 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Are you saying that it's working now?


Saqib Niaz commented Nov 11 '16, 5:36 p.m.

 I thanked for answering the question but the problem is not yet resolved. I have added a stream from my custom RM provider and a stream from Jazz's DM in the same GC stream. This GC stream is selected in configuration context of Jazz DM Module. Still I am unable to select my custom RM provider's artifacts in Jazz's DM.

Your answer


Register or to post your answer.