It's all about the answers!

Ask a question

How to create a requirement in DNG 6.x with a link type LinkTo to another Requiment [resolved]

Jean-Luc Johnson (8125) | asked Jul 21 '16, 9:54 a.m.
edited Jul 21 '16, 1:02 p.m.
I'm an experienced OSLC developer however I am stuck with a simple POST request unless it is a bug or the feature I'm looking for is not available. Please help me out! I face the issue on both Jazz v5 and v6 with configuration management enabled.

Creating a requirement is relatively easy. I was able to send a simple POST request to DNG and create a new requirement using both a REST client and my java sample code. In my scenario I need to create few requirements which are linked to each other using the link type Link (to/from). When I add a statement with the property "" that points to the actual resource, DNG just drops it. In the requirement RDF document, my statement looks like :
<j.0:Link rdf:resource="https://server:9443/rm/resources/_Tbaahsasajauasga-PQ" />

Even better, I have copied an existing requirement with a relationship Link (to) and I have pasted it into my REST client. It doesn't change anything. DNG always drops it.

I have just read here that  "It is possible from RDNG version 5.0.2 and up, older versions does not support those types of linking via the OSLC RM service provider. "

Here is my question:
How can I create a relationship LinkTo from a requirement to another within RDNG v6 with CCM enabled using a standard REST client?

3 answers

permanent link
Jean-Luc Johnson (8125) | answered Jul 21 '16, 1:00 p.m.
Well I have fixed the problem by myself. I have just followed all the steps I have described here against a fresh install of RDNG (6.0.2) and it worked.

permanent link
Jean-Luc Johnson (8125) | answered Jul 21 '16, 1:01 p.m.
edited Jul 21 '16, 1:01 p.m.
I consider this issue as resolved now. I wonder if it is possible to mark questions as solved!

permanent link
Gabriel Ruelas (1.1k13) | answered Jul 21 '16, 10:41 p.m.
Hi, The support to create RM link via OSLC was added in version 5.0.2.

Your answer

Register or to post your answer.