It's all about the answers!

Ask a question

no stream id is shown for scm list streams command

Mark Visontai (1111) | asked Jul 14 '16, 11:01 a.m.
edited Jul 15 '16, 12:48 a.m. by David Lafreniere (4.8k7)

can anyone have a guess why the command
scm.exe list streams -r [SERVER] -u [USER] -n [STREAM_NAME]
does not list the id of the stream(s)? Before yesterday the output was:
from today it is simply:
So ID and quotes disappeared. Interesting thing is that this happens only on one machine, on another one the output is the same as before. I checked, the scm versions are the same.

Build Id: RTC-I20140807-0233, version 3.2.300.v20140717_0143

One answer

permanent link
Alan Sampson (93749) | answered Jul 14 '16, 2:35 p.m.
edited Jul 14 '16, 2:53 p.m.
It looks like the alias display has been disabled in this system. The following command should show the object's repository alias:
scm.exe -a y list streams -r [SERVER] -u [USER] -n [STREAM_NAME]
scm.exe ---show-alias y list streams -r [SERVER] -u [USER] -n [STREAM_NAME]
The option is discussed here:
but no mention is made of how it can be permanently set.

Mark Visontai commented Jul 15 '16, 2:46 a.m.

Hi Alan,

I tried on my computer, the switch works (by default it shows the ids). Then I tried on the machine having this phenomena, it does not work, so for switch -a y it shows the same output as described (2nd). However there is a difference, on my machine the stream names are enclosed by double quotes, on this machine they are not. Is there some other global settings, maybe on the computer that can have this formatting / filtering effect?

Alan Sampson commented Jul 15 '16, 6:12 p.m.


I discussed this with a team mate; we can find nothing that would suggest this is a feature of the product and suspect that your environment has become damaged.  Have you tried reinstalling the CLI into a different location on that system to see if the problem persists?

Your answer

Register or to post your answer.