It's all about the answers!

Ask a question

RTC 5.0.2 support for IBM JDK 1.8


preethi ghalke (1111) | asked Jul 06 '16, 5:13 a.m.
 Hi,

We have RTC V 5.0.2 and we need to compile our sources with Java version 1.8. 
The compiler versions visible under windows->preferences->Java->Compiler->JDK Compliance -> Compiler Compliance level ,does not show 1.8  which is causing many eclipse errors of the type: "The type java.lang.CharSequence cannot be resolved"

Can you please tell the RTC client version that supports java version 1.8 ? is there a fixpack/upgrade available for existing  RTC V5.0.2 to support 1.8 ?

Any other pointers/references would be helpful .

Thanks in Advance!!

Regards,
Preethi.

2 answers



permanent link
Alan Sampson (93749) | answered Jul 07 '16, 12:16 a.m.
JAZZ DEVELOPER
The easiest way is to solve this is to install one of the Eclipse packages (e.g. Eclipse IDE for Java EE Developers) from the Eclipse 4.4.1 Luna download site http://www.eclipse.org/downloads/packages/release/Luna/SR1 than add the RTC plug-in via the p2-repo https://jazz.net/downloads/rational-team-concert/releases/5.0.2/RTC-Client-p2Repo-5.0.2.zip
and add a Java 1.8 JDK to the Installed JREs preferences page.

Be aware that the RTC 5.0.2 Eclipse plugin is not certified to run with anything newer than Eclipse 4.4.1 (Luna). See https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements50#B4_Eclipse_IDE_RTC_Eclipse_Clien for details.

permanent link
Ralph Schoon (63.2k33646) | answered Jul 06 '16, 5:18 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jul 06 '16, 5:19 a.m.
The Java versions that you use to compile your projects and the Java versions that are used to run the RTC Eclipse Client, Server, Build System are independent.

Add the 1.8 JDK/JRE to the available  to the Preferences/Java/Installed JRE's. this is just basic Eclipse handling and does not have anything to do with RTC itself. See http://help.eclipse.org/mars/index.jsp?topic=%2Forg.eclipse.jdt.doc.user%2Ftasks%2Ftask-add_new_jre.htm

Comments
preethi ghalke commented Jul 06 '16, 5:59 a.m.

 Hi Ralph,


Thank you for the prompt response.

We did add the 1.8 JDK/JRE like we did for its previous versions  1.7 and others, but still hit the eclipse errors.
So thought it could be the issue with Eclipse V 3.6.3 available with RTC 5.0.2  which does not allow the source version to be set as 1.8 ?

Can we upgrade the eclipse client to a higher version in RTC 5.0.2? 

Regards,
Preethi


Ralph Schoon commented Jul 06 '16, 6:37 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I can't help there. I would suggest to ask on Eclipse.org or search there or at stackoverflow.com for hints with Eclipse and Java 1.8.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.