It's all about the answers!

Ask a question

RQM Importer: unexpected error occurred on a receive


Karen Bown (2739) | asked Jun 10 '16, 8:36 a.m.
I'm trying to use the RQM Importer to "Export to Repository" using MS Word. I can't seem to figure out why I'm getting these errors:

Basic log.txt file
6/10/2016 8:12:30 AM:
--------------------------------------------------------------------------------
6/10/2016 8:12:30 AM:
SESSION: 6/10/2016 8:12:30 AM

6/10/2016 8:12:30 AM: Created 1 artifacts, sending to server
6/10/2016 8:12:30 AM: sending testcase0 named Test_Case_57
6/10/2016 8:12:30 AM: Server returned code
6/10/2016 8:12:30 AM: Error sending artifact 0 of type testcase to url https://HOST:9443/qm
6/10/2016 8:12:30 AM: finished writing artifacts

Mso2Rqm_Debug.log file
6/10/2016 8:12:30 AM:
--------------------------------------------------------------------------------

6/10/2016 8:12:30 AM:
SESSION: 6/10/2016 8:12:30 AM

6/10/2016 8:12:30 AM: Created 1 artifacts, sending to server
6/10/2016 8:12:30 AM: sending testcase0 named Test_Case_57
6/10/2016 8:12:30 AM: ERROR: <Unknown Caller Context>: RQMConnector: PutToServer - Error putting resource: https://HOST:9443/qm/secure/service/com.ibm.rqm.integration.service.IIntegrationService/resources/AIMM+S2+Lifecycle+Project+for+Requirements%2C+CCM%2C+SW+Dev+and+QA+%28Quality+Management%29/testcase/Test_Case_57
6/10/2016 8:12:30 AM: ERROR: <Unknown Caller Context>: The underlying connection was closed: An unexpected error occurred on a receive.
6/10/2016 8:12:30 AM: EXCEPTION: : The underlying connection was closed: An unexpected error occurred on a receive.
6/10/2016 8:12:30 AM:    at System.Net.HttpWebRequest.GetResponse()
   at Mso2Rqm_Common.RQMConnector.PutToServer(String url, String data)
6/10/2016 8:12:30 AM: EXCEPTION: : Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
6/10/2016 8:12:30 AM:    at System.Net.ConnectStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.HttpWebRequest.MakeMemoryStream(Stream stream)
6/10/2016 8:12:30 AM: Server returned code
6/10/2016 8:12:30 AM: Error sending artifact 0 of type testcase to url https://HOST:9443/qm
6/10/2016 8:12:30 AM: ERROR: <Unknown Caller Context>: ExcelExportRepositoryDialog: Error saving to url https://HOST:9443/qm of type testcase
6/10/2016 8:12:30 AM: EXCEPTION: : Object reference not set to an instance of an object.
6/10/2016 8:12:30 AM:    at RQMWordImport.WordExportRepositoryDialog.doExport(IList`1 artifacts)
6/10/2016 8:12:30 AM: finished writing artifacts
6/10/2016 8:12:30 AM: INFO: <Unknown Caller Context>: Exporting completed with 1 failures!

Accepted answer


permanent link
Mehul Patel (9695) | answered Jun 15 '16, 5:50 a.m.
FORUM MODERATOR
Karen,

You raised defect in RM project area instead of RQM. Any way I got the required files to investigate the issue. 

Shared file contains multiple issues related to sectionid definition.

- missing closing brackets at the end
testcase.Section("myns:com.ibm.rqm.planning.editor.section.caseTestDescription","Test Description")=Table(2).C7
testcase.Section("myns:com.ibm.rqm.planning.editor.section.caseTestPreparation","Test Preparation")=Table(2).C8

- incorrect UTF 8 characters for quote - 
testcase.Section(myns:1446479924943,Outline)=Table(2).C9 
it should be (please see the difference between " and ”)
testcase.Section("myns:1446479924943","Outline")=Table(2).C9 

Hope this helps.

Regards,
Mehul
Karen Bown selected this answer as the correct answer

Comments
Karen Bown commented Jun 15 '16, 7:07 a.m.

Hi Mehul, Yes, I learned that I put the defect in the incorrect place....still learning where everything is. But I have created a new defect this morning in the RQM Defect location: https://jazz.net/jazz02/web/projects/Rational%20Quality%20Manager#action=com.ibm.team.workitem.viewWorkItem&id=152875.

WOW, I have been looking at this over and over again and I didn't see those. Thank you so much!

However, even with the change I'm still getting the same error. I've updated the new defect with the updated files. Let me know if there is another error. I did make sure all the quotes were the correct type.

Thanks,
Karen



Karen Bown commented Jun 20 '16, 10:23 a.m.

Based on RQM Defect 152875....changing the 'testcase.Section("myns:1446479924943","Outline")=Table(2).C9'  to 'testcase.Section("myns:id_1446479924943")=Table(2).C9' worked. I was finally able to get a successful upload.

3 other answers



permanent link
Karen Bown (2739) | answered Jun 20 '16, 10:22 a.m.
Based on RQM Defect 152875....changing the 'testcase.Section("myns:1446479924943","Outline")=Table(2).C9'  to 'testcase.Section("myns:id_1446479924943")=Table(2).C9' worked. I was finally able to get a successful upload.

permanent link
Mehul Patel (9695) | answered Jun 14 '16, 2:49 p.m.
FORUM MODERATOR
Karen,

Please log a defect and attach sample file to the workitem, will respond to that.

Regards,
Mehul

Comments
Karen Bown commented Jun 14 '16, 3:16 p.m.

permanent link
Mehul Patel (9695) | answered Jun 14 '16, 1:33 p.m.
FORUM MODERATOR
Karen,

Are you consistently getting this? I would suggest to attempt with existing Sample file to check proper access on the project area. Is it working? Shared error is generic and not helpful to investigate cause of failure. I would also need sample configuration file and word document to investigate further.

Regards,
Mehul

Comments
Karen Bown commented Jun 14 '16, 2:44 p.m.

Hi Mehul,

Yes I am consistently getting this error with my created files. I tried using the TestScript inTables002.doc and .cfg; I didn't have any issues and they uploaded just fine. I had created my files based off of the ones here so I'm unsure as to what the issue is.

Can you provide an email address that I can send you the word and .cfg files to? I don't have an option to upload the files here.

Thanks, Karen

Your answer


Register or to post your answer.